3
$\begingroup$

I did a factory reset of my AMD video driver. I re-installed it, everything is fine.

Well, everything but eevee and the material preview.

This is a video of me enabling rendered mode on viewport preview on the default cube. https://gyazo.com/fdc0562351f662fa17de4008e675a604

This is a video of me enabling material preview mode on the viewport. https://gyazo.com/d8459c6f98bd9108854bd23e6830b11b

It also coincidentially gets all chrismas-y if I start turning some eevee options up. https://gyazo.com/af543efab540c2db605b978324ed336c

Ah, and this is Cycles, who seems to be working fine. https://gyazo.com/4e59ade211dcd654a23986704f5d3606

I have 3 versions of blender installed in my PC, they're all suffering from the same issue.

ANSWER: Seems to be a problem with the driver, a suggested solution is to turn on high quality normals, worked for me.

$\endgroup$
2
  • $\begingroup$ Susu, you're a BEAST. <3 $\endgroup$ – spinvs Dec 24 '20 at 21:56
  • 1
    $\begingroup$ It is certainly more fun than being a beauty... $\endgroup$ – susu Dec 24 '20 at 22:00