5
$\begingroup$

I thought it would be cool to use random selection and extrude along normals to make a sci-fi handle grip. Later, I found out that it didn't work quite the way I hoped and cannot be beveled. Is there some way to separate vertices like this:

enter image description here

Here's a quick example of the end result I hope to achieve.

enter image description here

I know I can extrude along individual faces instead of along normals, but I still want adjacent boxes to be attached.

There are too many to bother doing this by hand:

enter image description here

I'm still pretty new to Blender, so I appreciate any and all help/advice. Cheers :)

$\endgroup$
4
  • 1
    $\begingroup$ Another thing you can try in that situation is to select one vertex like in the screenshot above and run Shift+G > Amount of adjacent faces to select such vertices, then in the edges menu (Ctrl+E) run Edge Split. Those pieces should become separate and you can grab them a bit away from each other. This won't necessary work if operator meets more vertices with similar amount of faces around them $\endgroup$ – Mr Zak Dec 24 '20 at 17:53
  • $\begingroup$ I can't seem to find the "edge split" option under Ctrl+E. I searched for it using F3 and only found Split > Faces by Edges. Visually that sorta did the trick, but it creates a hole in the mesh that you can only see if you move the verts around (which is fixed by merging bottom set of overlapping verts). Am I doing something wrong? $\endgroup$ – Max Williams Dec 25 '20 at 22:04
  • 1
    $\begingroup$ Not necessarily, Blender devs appear to rename operators frequently and I don't use 2.9 often, this was in 2.8. It maybe is the command you found. I meant mostly this - i.stack.imgur.com/FsELX.gif. It is: 1. Shift+G to select. 2. Run splitting of faces by that edge 3. Run Select Linked flat faces 4. Convert selection to vertices, invert selection to have only extrusions 5.Scale connected extrusions down, those without connections move away from each other. This way depends on pattern of extruded faces, it won't work in some cases $\endgroup$ – Mr Zak Dec 26 '20 at 0:15
  • $\begingroup$ Ahhh! Okay, I see now. Yeah, I think I was using the right modifier. I just didn't link the flat faces. Thanks for introducing me to a couple new techniques! $\endgroup$ – Max Williams Dec 26 '20 at 2:58
4
$\begingroup$

Once gone into the Non-Manifold mesh path, it's hard to get back.

I suggest an hack: after the selection, Inset faces a little bit.

enter image description here

Make sure that Individual checkbox isn't active: enter image description here

Now, you have disconnected geometry you can easily extrude and bevel.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Ahhh! Very clever. I was hoping there would be a way around it. It's creative, yet simple (the best kind of solution). Thank you! $\endgroup$ – Max Williams Dec 24 '20 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.