0
$\begingroup$

I've done this before fine but I had scaling issues so I restarted my project. I created a bezier circle and moved the points around in edit mode to what I wanted. I set the 3D cursor to one of the points in edit mode that I wanted to be the origin. I went in to object mode selected the circle and then I used set origin to the 3D cursor in the Shift + S menu and it does not move.

It isn't a visual bug as the object rotates around the origin in its original place. Is there anything I've missed?

$\endgroup$
2
  • 2
    $\begingroup$ Can you show a picture of the situation? $\endgroup$
    – Carlo
    Dec 23 '20 at 23:24
  • 1
    $\begingroup$ The shift-s menu doesn't have an option to set the objects origin to the cursor. That's accessed from the Object > Set Origin menu. $\endgroup$
    – John Eason
    Dec 23 '20 at 23:52
0
$\begingroup$

As John Eason, set origin is not available in the ShiftS pop-up menu, you need to go in Object mode and right click > Set Origin > Origin to 3D Cursor.

Or enable the Transform Affects Only > Origins option and in that case you can use the ShiftS > Selection to 3D Cursor as in that case it will move the origin:

enter image description here

$\endgroup$
5
  • $\begingroup$ Apologies I mistakenly wrote shift s menu. $\endgroup$
    – user113397
    Dec 24 '20 at 22:23
  • $\begingroup$ The workflow I'm following is. Edit mode for the bezier curve and select a point. shift+s and select cursor to selected. Object mode right click while bezier curve selected and set_origin > origin_to_3d_cursor Origin point doesn't move. I did set the options to transform affects only origins $\endgroup$
    – user113397
    Dec 24 '20 at 22:29
  • $\begingroup$ what you describe should work, maybe show some pictures or a video clip. Note that the solution withAffect Only Origins is another solution as explained $\endgroup$
    – moonboots
    Dec 24 '20 at 22:34
  • $\begingroup$ Just deleted all my work and tried it again and it worked fine. I must've carried out an action on my first curve that now prevents the origin from moving. Wish I knew what it was to avoid redoing work in the future. $\endgroup$
    – user113397
    Dec 24 '20 at 22:43
  • $\begingroup$ ok, that was weird ;) $\endgroup$
    – moonboots
    Dec 24 '20 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.