0
$\begingroup$

So I'm working on this geometric shape that looks like this:

enter image description here

enter image description here

I've converted to tris and then all my tris to quads. So there shouldn't be any ngons left in the geometry. I've also recalculated all my face normals from the outside.

Then I add my subdivision surface modifier and I get quite a few distortions/pinchings/crumplings:

enter image description here

enter image description here

and here is a view where I add more levels:

enter image description here

How do I go about making the geometry smooth out better? Do I need to do some topology type stuff? Or is my geometry all messed up and needs to be remade?

Edit:

here is the blend file -

$\endgroup$
7
  • $\begingroup$ You need more supporting loops for subsurf to work well. Topology Guides is a good resource to look at. $\endgroup$
    – Timaroberts
    Dec 23 '20 at 17:35
  • 1
    $\begingroup$ Another issue in your case is not tri's or n-gon's, but poles (vertices with more than 4 connecting edges). These are causing your "pinch points". Like tri's and n'gons, these can be acceptable, but try to keep them towards the middle of flat areas. $\endgroup$ Dec 23 '20 at 17:41
  • $\begingroup$ @ChristopherBennett - how do I go about reducing/removing poles? $\endgroup$
    – j will
    Dec 23 '20 at 17:50
  • $\begingroup$ It's mostly a topology practice kind of thing, so there's no real one-size-fits-all solution. However, one thing you could try is to go into the Object Data Properties tab, and under Remesh, pick "quad", and try running the Quadriflow Remesh. It works like magic on some things. $\endgroup$ Dec 23 '20 at 17:53
  • $\begingroup$ @ChristopherBennett i don't have the quadriflow option. I only have these options: blocks, smooth, sharp, and voxel $\endgroup$
    – j will
    Dec 23 '20 at 20:29
2
$\begingroup$

Ok, so the first thing I noticed (by turning on face normal overlays) is that the normals were going all over the place. To me, this suggested duplicate faces, so I used a Merge By Distance operation (Press M (merge) in the viewport and select "distance"). I increased the "merge distance" to .0101 and it removed 521 duplicate vertices which solved most of the problem, but not all.

Merge1

Upon investigating the rest, I noticed that there are a number of interior faces - faces inside your mesh. Also, for some reason, the second time I tested this, deleting the faces left some "loose edges" - floating lines that still made it look strange even though the faces were gone. If yours still looks strange after the subsurf is applied, look for these inside the mesh (I found a couple in the large "tank" section).

Merge2

Regardless, deleting them seems to solve the rest.

Done

There are also some areas on the outside that have duplicate edges (this could be an unwanted result of the merge operation, but I can't be sure.) Deleting them (not dissolving them) seemed to clean that up.

Edges1

Edges2

So this is mostly solved, but there are a couple of new N-gons you will have to deal with somehow:

Ngon

$\endgroup$
4
  • $\begingroup$ :O :O :O :O :O :O :O :O :O :O :O :O :O $\endgroup$
    – j will
    Dec 23 '20 at 21:11
  • $\begingroup$ that all worked :0 there were a couple of edges i had to get rid of as well $\endgroup$
    – j will
    Dec 23 '20 at 21:31
  • $\begingroup$ Yeah, although its not as perfect as I thought. I added to the answer showing there is still some work to do. This may possibly be avoided by fine tuning the merge operation to make sure that no unwanted (wanted) vertices get removed. $\endgroup$ Dec 23 '20 at 21:40
  • $\begingroup$ this helped so much. I spent a lot of last night just trying merge individual groups of vertices :P $\endgroup$
    – j will
    Dec 23 '20 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.