1
$\begingroup$

In a Cycles scene, I need to render glare around the warp engines, however, the resulting PNG always has the glare cut off when it leaves the body of the ship. This problem is present in the output PNG and is therefore not just limited to the viewer.

I know this is possible to overcome somehow with PNG as I have done it before, but I do not have the node setup anymore. Can anyone please point me in the right direction?

This is the node setup I have at the moment: Node setup with glare cut off

$\endgroup$
4
  • 1
    $\begingroup$ Read: blender.stackexchange.com/questions/57816/… $\endgroup$ – susu Dec 22 '20 at 18:58
  • $\begingroup$ That is where I started. As you can see above, I am using the node setup they have been suggesting, but the saved PNG still does not contain the glare on transparent background. $\endgroup$ – Ondrej Dec 22 '20 at 19:31
  • $\begingroup$ Read the whole page linked.PNG is a terrible format to save pixels that are emissive and transparent (as glows, halos or fire). Having said that, the viewer problem was fixed on 2.92 $\endgroup$ – susu Dec 22 '20 at 19:35
  • $\begingroup$ I have read it several times completely. I am using OpenEXR, but the problem is still there. I also know about the viewer being fixed in the newer version, but as I said above - the viewer is not the problem I'm trying to solve. I need the ability to save something - EXR, PNG or whatever, that when opened in photoshop will have the glare on transparency. $\endgroup$ – Ondrej Dec 22 '20 at 19:38
1
$\begingroup$

This is not my solution, I have this saved on my drive, but I cannot find the original post either.

enter image description here

$\endgroup$
1
  • $\begingroup$ This isn't it - the resulting image always has altered colours, which is a natural result of this method. I think the one I was using before was working with the Alpha Over node. $\endgroup$ – Ondrej Dec 22 '20 at 16:18
1
$\begingroup$

1n 2.92 there is no need to do anything else than a glare node.

enter image description here

I don't use photoshop (or any products by Adobe), so I have no clue how Photoshop is misinterpreting the associated alpha or what you need to do to fix that. I figure there might be an option to associate (or "premultiply") the alpha channel. You can do the compositing directly in blender, or use Natron, Nuke, Fusion or any other software that can deal with alpha channels properly.

$\endgroup$
2
  • $\begingroup$ I am now able to achieve this, thanks to switching to 2.92. What format do you use for saving? $\endgroup$ – Ondrej Dec 22 '20 at 21:09
  • $\begingroup$ I'm asking because when I save this into OpenEXR (RGBA) and open it in photoshop, it asks me whether to take the alpha information as alpha channel or transparency. The first results in glare outside the ship on black background while the other results in transparent background without glare. $\endgroup$ – Ondrej Dec 22 '20 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.