0
$\begingroup$

When i spawn in an object in 2.82.7 with a plugin/script or while clicking the button the object is invisible here is an example of a spawned in sphere while its selected

enter image description here

  1. There is no need for lights because im in "solid mode"
  2. When unselected the object is completely invisible (there is no outline)

Now the only way i found to fix this is i switch from "object mode" into "edit mode" and the moment i do that this happens

enter image description here

This also works if i press this button

enter image description here

If i switch back to "object mode" or disable the icon above it returns back to being invisible and the only way i found to make it visible is if im in "edit mode" (or the icon from above is activated) and then i deselect the object (by left clicking on empty space) and after that going in "object mode" Here are all the steps in picture form

Deselect

enter image description here

object mode after deselecting

enter image description here

and now the object is visible and the "icon" from above is not active now

here is an example

enter image description here

if i select something that isnt an object or camera and go to "edit mode" and do all of the steps it doesnt work

also if i go back to "edit mode" and select a face and go to "object mode" without unselecting it it turns invisible

example

enter image description here

enter image description here

btw if i go up to a higher version of blender for example 2.9 then blender doesnt start for me but crashes on the "start screen" the like "command window" with all of the "words" before it would launch

I have an AMD processor and an AMD graphics card

$\endgroup$
10

Browse other questions tagged or ask your own question.