1
$\begingroup$

I downloaded the compound collision change example from blender demo files and just added a cube with a rigid body in there. It does not fall at all.

I tried to delete bake and baked again -> same result

What am I missing here?

Blend file:

cube rigid body settings

scene rigid body settings

result of moonboots answer:

enter image description here

here my new blend file with moonboots proposed changes:

$\endgroup$
4
  • $\begingroup$ Please add images of your settings and interface. Information needed to provide an answer should be visible in your question, and not rely on downloading files. Thanks $\endgroup$ – Timaroberts Dec 22 '20 at 11:57
  • $\begingroup$ i did....want to see more...or something specific? $\endgroup$ – Chris Dec 22 '20 at 12:09
  • $\begingroup$ @timaroberts: nice, that you "corrected" my text and make it worse in some parts...if you use some "automatic" tools to make uppercases, please check(!) whether it makes it right. In my case your tool capitalizes alle words of my caption which makes abolutely no sense at all. Thank you. $\endgroup$ – Chris Dec 22 '20 at 13:02
  • $\begingroup$ It is called title case as opposed to sentence case. But anyway, you are free to rollback if you wish. $\endgroup$ – Timaroberts Dec 22 '20 at 13:06
1
$\begingroup$

You need to do 3 things:

  • Delete the bake:

enter image description here

  • Apply the scale of the small cube:

enter image description here

  • Choose Shape > Mesh instead of Convex Hull for your big triple cube object, otherwise it will act like a big box and it will kick out the other objects:

enter image description here

$\endgroup$
5
  • $\begingroup$ i did as you wrote and the good thing: the box is moving, the bad thing: everything is blowing up like an explosion.... see my pic in my updated question $\endgroup$ – Chris Dec 22 '20 at 13:37
  • $\begingroup$ Delete the bake, select the big structure and choose Mesh instead of Convex Hull and it should work, sometimes it looks like there's a refresh problem but on my computer it works. Maybe try to hide and unhide the big object to see if it refreshes? $\endgroup$ – moonboots Dec 22 '20 at 13:49
  • $\begingroup$ ok, thank you very much! Now it works as expected! $\endgroup$ – Chris Dec 22 '20 at 14:00
  • $\begingroup$ so was it a problem of refresh or did you forget one of these steps? $\endgroup$ – moonboots Dec 22 '20 at 14:01
  • $\begingroup$ of course my fault. I thought you meant my cube to be as a mesh object because i read too fast and too lazy...when i set the big structure to mesh it did not work either. Then i moved the cube to another collection and deleted bake again and baked ...it worked. And i am glad it did. $\endgroup$ – Chris Dec 22 '20 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.