5
$\begingroup$

I am trying to add particles to a surface over which I have added a texture and they look like they are floating in the air. I know this is because they are sitting on the actual model but is there a way to get around this? layout render view nodes

$\endgroup$
1
  • 4
    $\begingroup$ This is interesting. I don't think the particle systems can get access to this kind of information. Given the "simpleness" of the displacement, you could use an actual pre-rendered wave texture inside a Displace modifier, which in turn can be accessed by the particle system. You can also use a Wood texture for instance and tweak the settings ? $\endgroup$ – Gorgious Dec 22 '20 at 10:47
3
$\begingroup$

As Gorgious says, it seems like the particle system can't take the Displacement node into account, in that case what you can do is baking the current displacement setting:

  • Unwrap you object with the Smart UV Project option
  • In the Shader Editor plug the wave texture only
  • Create a new Image Texture node, create a new 32-Bit Float image, keep the node selected:

enter image description here

  • Bake with Bake Type > Emit:

enter image description here

  • Here is what you should get:

enter image description here

  • Create a Displace modifier, put it above the ParticleSettings modifier, choose Coordinates > UV:

enter image description here

  • Load your texture:

enter image description here

  • In the Shader Editor, replug only the Principled BSDF:

enter image description here

  • It should work:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.