0
$\begingroup$

I searched in the forum and saw the other post of the same question posted 4 years ago, tried to follow it but found I couldn't do it in 2.9.

So I created a path and converted it to mesh. Exit the Edit Mode, with the curve selected, I hit F3 to search for Simplify Curves. By applying it to the curve, it gives me an error message:Failed to find '3D Viewport: Add (Shift A) ▶ Curve ▶ Curve Simplify'

Is there a different way to do it in 2.9?

$\endgroup$
2
  • 1
    $\begingroup$ simplify curve doesn't work on mesh objects. Once you converted the curve to mesh, you can no longer use simplify curve on that object. It is not a curve anymore... $\endgroup$
    – Timaroberts
    Dec 21 '20 at 23:50
  • $\begingroup$ plus, Curve SImplify is an addon, you need to activate it, is it your problem? $\endgroup$
    – moonboots
    Dec 22 '20 at 11:57
1
$\begingroup$

Consider the following gif:

enter image description here


Here I have simply added a curve object, and then used Shift+A>simplify curve and then repeated the process with anew curve and an intermediate step of converting the curve to mesh.

As you can see, the option for simplify curve is unavailable with the new mesh object, as the operator is only usable for curve objects. So, in your situation, either convert back to curve, or add a new object if it is not too tedious of a task.

Here is the documentation for the Simplify Curves add-on.

$\endgroup$
1
  • $\begingroup$ Thank you for the explanation! But the problem is I want to make a plane out of the curve, is there a way to not having so many vertices after I convert the curve to mesh? $\endgroup$
    – hiro ober
    Dec 22 '20 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.