0
$\begingroup$

I'm pretty new to blender and especially new to working with materials and lighting as I have done rendering in other programs previously. My problem is the reflections from the objects under the glass as seen below. enter image description here

But when I am in the shading viewport I don't get these relfections and it looks just fine. enter image description here

Thanks for any help you might provide :)

$\endgroup$
4
  • $\begingroup$ Just to be sure: Is the blue spot a censor bar? The first screenshot uses the Cycles render engine. The reflections are probably caused by light and the glass material. The second screenshot is the material preview. It uses the Eevee render and a HDR image, and it fakes a lot of the light to give you a quick overview of the materials. That's why the look different. $\endgroup$ – Blunder Dec 21 '20 at 21:39
  • $\begingroup$ The shading viewport uses Material Preview mode which uses a hidden HDRI for lighting and reflections. To add this to your own scene, click on the box that says "object", and change it to "world" (world shading). Add an Environment texture and connect it to the background. Blender's built in HDRI's are in ../2.92/datafiles/studiolights/world. You can also download your own from online - a popular place is HDRI Haven. To view your HDRI, you must be in rendered preview mode (press Z in viewport and select "rendered") $\endgroup$ – Christopher Bennett Dec 21 '20 at 21:39
  • $\begingroup$ @Blunder probably some branding $\endgroup$ – Allen Simpson Dec 21 '20 at 21:41
  • $\begingroup$ Also, if you're talking about the "double reflections" in the Cycles render, this is a result of refraction. The shading tab (Material Preview) uses a render engine more similar to eevee. If you're using cycles, you should be able to get away with just using a Glass BSDF instead of the Principled/Transparent combo. You may need to adjust the IOR a bit because of it's "thinness". $\endgroup$ – Christopher Bennett Dec 21 '20 at 21:53
2
$\begingroup$

Reflections are part of what makes glass look like glass. The issue is not so much with the material (making a shader with no reflections completely is quite easy, but will make the glass look like there is no surface at all).

Look at images of watches and do a search on how to photograph them. The important thing that you will notice is how the surrounding elements play a crucial role in the scene. You want reflections that show the glass, but you want also some black (or dark) elements reflected on the surface that make the transparency more evident. So you have to be strategic about how objects and lights are placed around the watch.

Read: How to turn off reflections on glass

Also, when dealing with elements behind glass, the thickness of the glass will play a crucial role. If the glass has no thickness (like a a plane) then the glass material will behave like a single glass solid, as if the insides were encapsulated completely in a glass block instead of being behind a thin piece of glass. The glass has to have a realistic thickness.

To create a shader for elements behind glass in cycles read:

How to illuminate the darkness inside glass objects in Cycles?

Objects behind glass appear too dark

As a final note: a plain HDR of trees as environment is not the optimal way to light a scene like yours.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.