0
$\begingroup$

The next image will show the problem I am having.

Material View

I've been playing around trying to fix this, I had this issue ages ago once but I never found a fix, a year later it has cropped up again. I have checked face orientation, normals are facing the correct way, there are no extra faces inbetween those sections, I have merged vertices by distance, applied rotation and scale, my seams and UV seem alright and I have no marked sharp edges. Images shown below, what have i missed?

Above is the blend file.

face orientation

Merge by distance

Normals and no extra faces

Rotation and Scale

Seams

UV Layout

After trying suggested fixes

$\endgroup$
15
  • $\begingroup$ Hello, please share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Dec 15 '20 at 16:52
  • $\begingroup$ It's hard to tell, but it looks like it may be a Blend Mode issue. Try changing Blend Modes in the Material Properties tab. I can't tell if you're using transparency or not, but if not, make sure it's set to opaque. $\endgroup$ – Christopher Bennett Dec 15 '20 at 16:53
  • $\begingroup$ @moonboots I believe I have now uploaded the blend file now, I have removed all other content apart from the issue asset $\endgroup$ – Dmitry Dec 15 '20 at 17:02
  • 2
    $\begingroup$ Try changing the color space of the image texture you're using for your alpha from sRGB to non-color $\endgroup$ – Christopher Bennett Dec 15 '20 at 17:17
  • 1
    $\begingroup$ In the material, disable the Show Backface option? $\endgroup$ – moonboots Dec 15 '20 at 17:30
1
$\begingroup$

Edit: So my answer fixed the problem on my computer but not on yours apparently...

Show Backface seems to be the option you want to disable, it will affect the Material Preview in Cycles, it won't affect the Render, except in Eevee:

enter image description here

$\endgroup$
5
  • $\begingroup$ file:///I:/004%20Personal%20Work/StackExchange/Sading/InkedStill%20not%20working_LI.jpg So it still seems to be having issues. I have managed to fix it on my main file but that was through various different ways, including changed it to Alpha Hashed and Non colour in the alpha material. I think your way does fix it but not always maybe? I'm not sure $\endgroup$ – Dmitry Dec 15 '20 at 17:53
  • $\begingroup$ I can't see the link ;) $\endgroup$ – moonboots Dec 15 '20 at 17:54
  • $\begingroup$ Whoops :P can I edit it into your answer? im not very good at this am i haha EDIT* I added it to mine $\endgroup$ – Dmitry Dec 15 '20 at 17:56
  • $\begingroup$ you can edit your question, weird that it doesn't fix the problem though, it works fine here $\endgroup$ – moonboots Dec 15 '20 at 17:58
  • $\begingroup$ Yup just did cheers, its the final image. Very odd indeed, like I mentioned it did seem to get fixed but the fix seems random in a way $\endgroup$ – Dmitry Dec 15 '20 at 18:00
1
$\begingroup$

So I found the Solution with the help of @moonboots and @ChristopherBennet, here are the images explaining.

  1. If using an Alpha Blend or Alpha Hashed mode with an alpha texture node, make sure Non Colour is selected in the colour space drop down.

Shader settings

  1. Disable "Show Backface" under the "Materials tab", "Viewport Display."

Disable Show Backface

  1. Get rid of any extra materials or make sure they follow the same settings, if using multiple objects, separate objects and texture separately.

Extra materials

$\endgroup$
1
  • $\begingroup$ @moonboots So I think because these materials were attached to it and they had the BackFace enabled and Colour Space set to sRGB they were conflicting with the main material. I was able to re-repeat these steps and consistently fix the problem $\endgroup$ – Dmitry Dec 15 '20 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.