0
$\begingroup$

Just created a simple character with a head, body, and legs. But when I use try to rig it, the joints get distorted. I tried to use empty groups (since it worked in 2d), but the parts wouldn't move.

Normal/Resting Position:

enter image description here

The tree:

When I move a model:

enter image description here enter image description here

Weight Paints:

enter image description here enter image description here enter image description here enter image description here

Here is the file: https://github.com/daarush/BlendersTestings

Please tell me if you cannot access it.

$\endgroup$
12
  • $\begingroup$ If you want your model to behave as rigid parts please state so. If you want you model to behave as organic rubbery flexible parts please state so. I am guessing at this point. Please show you model in weight paint mode. $\endgroup$ Dec 15 '20 at 0:11
  • $\begingroup$ Please restate [the joints get distorted] clearly. Again guessing. Do you mean meshes are intersecting? You probably can consider a tutorial on Armatures and Blender on the famous website that has a name that rhymes with noonoob. $\endgroup$ Dec 15 '20 at 0:12
  • $\begingroup$ Can you take a look again @atomicbezierslinger. $\endgroup$
    – Overdrive
    Dec 15 '20 at 0:16
  • $\begingroup$ Please show your entire screen in weight paint mode. So we can see bone selected and the associated paint, and whether or not you think the weight is correct. A full picture of the weight paint mechanism not tiny bits. A picture with an arrow that indicates ... this area is a problem because .... $\endgroup$ Dec 15 '20 at 0:16
  • $\begingroup$ I am new to blender, how do i do a entire screen? $\endgroup$
    – Overdrive
    Dec 15 '20 at 0:18
0
$\begingroup$

It looks like you have 5 pieces rather than 4. Include both head pieces with parenting to the bone.

$\endgroup$
2
  • $\begingroup$ no, it only had one head piece $\endgroup$
    – Overdrive
    Dec 15 '20 at 0:38
  • $\begingroup$ I can send the file to you, if you'd like. $\endgroup$
    – Overdrive
    Dec 15 '20 at 0:52
0
$\begingroup$

TL;DNR: Here's your rigged character:

You have several problems.

  1. Each of your four objects is non-manifold
  2. You shouldn't parent when there are transforms applied to the armature.
  3. Your feet bones don't have parents so there's no single bone you can use to move the entire object in pose mode.

Your best bet would be to parent each object to its own bone separately.

Here are the the steps I took to fix the rigging.

  1. Undo your current attempt. For each of the objects:

    • Select the object in object mode.
    • go to Object properties; open the Relations panel and click the x to delete the armature as parent.
    • go to Modifiers and delete the armature modifier.
    • go to Object Data properties and remove all of the vertex groups.
    • Clear all transforms by typing AltGAltRAltS
  2. While you're at it, fix the duplicate vertices.

    • Select the object in edit mode, select all of the vertices and remove duplicates by typing M and selecting by distance from the drop down menu.
  3. Fix the rig itself

    • Select the rig in object mode
    • Make the rest of this easier by going to Armature Data Properties; opening the Viewport Display panel and selecting In Front
    • Clear all transforms by typing AltGAltRAltS
    • Select the rig in Pose mode and clear all transforms by typing AltA to deselect all bones and then A to select all bones and then AltGAltRAltS to clear all transforms.
    • Select the rig in edit mode.
    • Select each of the leg bones and then select the body bone.
    • Type CTRLP to parent and select Keep Offset from the dropdown menu.
  4. Finally, you can now parent the objects to the bones. For each object:

    • Select the object
    • Shift Select the Armature
    • Enter pose mode.
    • Select the bone the object should be parented to.
    • Type CTRLP and select bone from the drop down menu.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.