2
$\begingroup$

My scene has about 4 point lights which makes it reflect on the glass with white spots, you can see it in the picture. how do i fix it enter image description here

Here is my lightingenter image description here

I tried turning off glossy option in ray visibility but that didn't workenter image description here

so how do i fix it

$\endgroup$
5
$\begingroup$

Glass is supposed to be transparent and reflective (and other thing is refractive, can disperse and absorb light, etc). If you take away the reflections then it will no longer look like glass.

Instead of trying to suppress the reflections, you need to use them to your advantage, so that they feature the characteristics of your object.

Using point lights or very small sources will always result in the kind of ugly spots that you dislike.

enter image description here

That is the very reason why photographers never use point light sources to light shiny objects.

Do an internet search for articles on how to photograph glass and shiny objects. The same principles apply for 3D rendering.

Use large area lights and white panels to light the scene, so that the reflections are much larger and more pleasant (or less distracting). Here's a single very large area light on the same scene: you can see the transparency, reflectiveness, roundness of the object and the overall shape of the object inside the glass.

enter image description here

Delete all the lights you are using, set the world to a black environment, and start with a single large light and play with it, pay attention at what happens with the reflections and the shape of the object, move it and play with the size until you find something that you like, and that suits your needs. Strategically add more lights, or white or black planes, until you get the results you are after.

The same principles that apply to shiny objects can also be used on glass: You are not lighting the object but creating an environment that gets reflected on it.

enter image description here

Read also: Why does an object with a glossy shader render in black?

$\endgroup$
1
  • 1
    $\begingroup$ Hey :). Not to sound weird, but I'm just learning so much from your posts. And not only about blender. So, thanks :). $\endgroup$ Dec 13 '20 at 19:50
0
$\begingroup$

Select the light and in Properties panel > Object > Visibility, disable the Glossy option:

enter image description here

$\endgroup$
2
  • $\begingroup$ it doesnt work it just doubles the white spots $\endgroup$ Dec 13 '20 at 17:48
  • $\begingroup$ sorry I meant select the light ;) $\endgroup$
    – moonboots
    Dec 13 '20 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.