0
$\begingroup$

enter image description here

The right skeleton is the one that is rigged to the mesh and the left skeleton has a running animation but not the same position as the right idle skeleton. I need to paste the keyframes from the left skeleton into the right skeleton so the mesh will do it too.

$\endgroup$
8
  • $\begingroup$ do they have the same bone names? in that case you can simply select them in the Dope Sheet in Action Editor mode $\endgroup$ – moonboots Dec 11 '20 at 20:57
  • $\begingroup$ Thanks, it kinda works now, I don't use dope sheet much so I didn't think to use it. I have it kind of working but the animation on the right skeleton looks weird and it walks funny, so I just need to copy the stance of the left skeleton and paste it to the right skeleton so the animation runs normal. How could I do that? $\endgroup$ – HoofMcPoof Dec 12 '20 at 2:58
  • $\begingroup$ maybe share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Dec 12 '20 at 5:08
  • $\begingroup$ I added the blend file, I just need one of those skeletons to start in the default pose and then move into the running animation, if you just add the running animation to the default skeleton then it's animation is different and looks weird. $\endgroup$ – HoofMcPoof Dec 12 '20 at 9:15
  • $\begingroup$ as I said, switch to Dope Sheet > Action Editor, select the armature on the right, in the Action dropdown menu select the same action (the first one), it works exactly the same, BUT, as the armature on the right has a different rest pose, of course it won't have exactly the same pose at a given frame, if you want that they need to have the exact same rest pose $\endgroup$ – moonboots Dec 12 '20 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.