0
$\begingroup$

So I was watching a video and practicing what the video tells. I made the following model while practicing, the thing is I believe the topology must be alright according to the video but there are lighting artifacts as seen in the below pictures. I couldn't understand what is wrong with my topology. The video: https://youtu.be/HGL6QpVRyXk

the model

artifacts 1

artifacts 2

$\endgroup$
1
  • 5
    $\begingroup$ your topology is good but you must have activated Shade Smooth, to deactivate, right click > Shade Flat $\endgroup$
    – moonboots
    Commented Dec 10, 2020 at 15:24

1 Answer 1

2
$\begingroup$

This is happening because the mesh object is set to "Shade Smooth," which averages the perpendicular vectors of the... oh, bother. It makes the lighting behave as if the surface were curvy instead of made up of flat faces. This is useful when trying to make spheres that do not look like disco balls, or pretty much anything curved in CG.

Of course, since this is a floor map, you want flat shading. You can do this in object mode with "Shade Flat" in the object menu, or you can go to the properties editor -> mesh tab -> Normals panel -> enable Auto smooth. This will conveniently not average the normals if the angle is above a certain threshold, which is great for most projects.

Here's more detailed information.

https://docs.blender.org/manual/en/latest/modeling/meshes/structure.html?highlight=auto%20smooth

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .