0
$\begingroup$

Using the setup below ,a transparent gradient shader does not get generated.

How to generate a Tranparency "Gradient" Shader in Eevee?

enter image description here


UPDATE 1


Tried the below 2 solutions by @Moonboots but was not getting the same result. Also checked switching Blend mode to Alpha-Blend and unchecking 'Show Backface' ,but not getting transparency.What's missing?

enter image description here

enter image description here

$\endgroup$
4
  • 2
    $\begingroup$ If you are using EEVEE, you need to change the Blend Mode of the material. It's in the material properties tab. Change to anything other than Opaque (I find Alpha-Blend works nicely for most situations). $\endgroup$ – Christopher Bennett Dec 10 '20 at 14:31
  • $\begingroup$ please share your last file $\endgroup$ – moonboots Dec 11 '20 at 11:02
  • $\begingroup$ Blend file uploaded(plz find in above question) $\endgroup$ – starzar Dec 11 '20 at 11:34
  • $\begingroup$ Gradient Node has to be connected first to the alpha socket and then the Color ramp node inbetween. $\endgroup$ – starzar Dec 11 '20 at 17:30
1
$\begingroup$

I'm not sure to understand your node organization, in my opinion you should choose between the alpha and the transparent solution, which would give the ColorRamp plugged into the Alpha socket:

enter image description here

or the ColorRamp into the factor of the Mix Shader between the Principled BSDF and the Transparent:

enter image description here

Also, maybe deactivate the material Show Backface option?

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.