2
$\begingroup$

I want to convert a hair particle to mesh, but whenever I press the convert button in the modifiers panel it converts to a curve. I can then give depth to the curve, but I can't give it the same tapered effect I could get in the particle settings. How do I fix this?

More info:

What I want: enter image description here

(I got this by rendering it)

What I have: enter image description here

(The converted curve)

$\endgroup$
5
  • $\begingroup$ You can convert the curve to a mesh. $\endgroup$ Dec 10 '20 at 7:49
  • $\begingroup$ But when I convert to mesh it loses it's tapering and turns into a line. $\endgroup$ Dec 10 '20 at 20:08
  • $\begingroup$ Yeah. I'm not sure then. I thought using a Bezier Curve as a Taper Object for the (hair) curve would be able to adjust the taper, but it doesn't seem to want to play nice with multiple hair particles (curves). I played with it a bit, but I don't think I had any more success than you. Maybe you'll have more luck with the taper object that I did. $\endgroup$ Dec 10 '20 at 20:32
  • $\begingroup$ can you put an image of what you are looking for? $\endgroup$ Dec 12 '20 at 19:49
  • $\begingroup$ Maybe sharing your file could help to have a fast answer. Taper object inside curves geometry looks like a good option Example imgur.com/a/Co0yVTT $\endgroup$
    – Emir
    Dec 13 '20 at 4:18
1
+50
$\begingroup$

From the Blender Manual on taper objects.

The taper curve is evaluated along the local X axis, using the local Y axis for width control. Note also that: Tapering a curve causes it to get thinner towards one end. You can also alter the proportions of the Taper throughout the tapered object by moving/scaling/rotating the control points of the Taper Object. The Taper Object can only be another curve. Editing the handles and control points of the Taper Object will cause the original Object to change shape.

In order for this to work:

  • It must be an open curve.

  • The taper is applied independently to all curves of the extruded object.

  • Only the first curve in a Taper Object is evaluated, even if you have several separated segments.

  • The scaling starts at the first control point on the left and moves along the curve to the last control point on the right.

  • Negative scaling, (e.g. negative local Y on the taper curve) is possible as well. However, rendering artifacts may appear.

  • Might need to increase the curve resolution to see more detail of the taper.

  • With closed curves, the taper curve in Taper Object acts along the whole curve (perimeter of the object), not just the length of the object, and varies the extrusion depth. In these cases, you want the relative height of the Taper Object Taper curve at both ends to be the same, so that the cyclic point (the place where the endpoint of the curve connects to the beginning) is a smooth transition.


In the example below, Suzanne has had a simple hair system converted to curves, then a bezier curve is used as a taper object.

example gif


The geometry settings for the converted hair are below:

enter image description here

The hair curve also has a subdivision surface modifier to further smooth the shape after conversion.

The hair system itself is nothing special, all default settings except that the count is changed to be much less than the default 1000 (only 36)and for suzanne is using a density vertex group for emission. Also, in order to prevent the hair from detaching from the emitter due to the forces after being converted, I used emit from volume rather than faces, or vertices.

The shape of the hair is created with two forces, turbulence and vortex

In short, as long as the curve is along the correct axis, as shown in the example you should have no problem reproducing in your own project. Once satisfied with the final shape of the curves, you may convert them to mesh via Object ‣ Convert To ‣ Mesh

I have also included a finished sample file demonstrating the taper on suzanne, hopefully it will get you in the right direction.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.