I'm new to Blender and I was getting hooked on this program. I was working on a project using the viewport shading set to Rendered with the EEVEE render engine because I don't have a very powerful graphics solution. However, last days, the materials on this project didn't appear in viewport shading, or even in the final render. All the previews of the materials have become completely transparent.

I thought it was just the damaged project, but unfortunately this problem occurred on all old and new projects. I leave some images and a file as examples. Opening the file on my friend's computer, the materials work (EEVEE), but I can't work on his machine. One more thing, using Cycles the materials work, but using EEVEE they don't work. Unfortunately I can't work using Cycles, it takes too much time and sometimes blender crashes.

I tried looking online for solutions to problem like mine or who had a similar experience and I have already tried to apply their various solutions, but none of these solve my problem:

The last topic I didn't understand what should happen if I press Ctrl + Alt + B? Under the View menu, I didn't find View Borders, but using the blender command search I found Clear Render Border, I tried to activate the command but it didn't work.

I also tried reinstalling Blender, but it doesn't seem to work and it even remembered my personal configurations! I also tried installing add-ons to try to find an alternative to the EEVEE engine (Radeon pro render [rpr], EEVEE-Preset) but no one of them are for me or repair the EEVEE engine.

If you find this information useful to solve my problem as computer I have a

  • Ryzen 5 2600 processor,
  • Radeon Rx 580 4 GB graphics card
  • 16 GB of RAM.

Just a clarification, I use Blender 2.90.1, can someone tells me a way to restore the correct functioning of EEVEE materials?
Unfortunately I no longer know where to turn and I'm crazy to see all my projects be transparent.

rendering with Cycles rendering with rpr rendering with eevee file di esempio test_box.blend

  • 2
    $\begingroup$ Try doing this, it fixed the problem for me youtube.com/watch?v=mDJ8IR6TvLc&ab_channel=RECREATECGI $\endgroup$
    – Indie Gael
    Commented Dec 11, 2020 at 16:11
  • $\begingroup$ @IndieGael Thank you very much. That video solves my big problem, but I don't understand why it works if It is checked "High Quality Normals" in Render properties -> Performance. The only remaining problem is that under material Properties the previews remain transparent. Is there any suggestion? $\endgroup$
    – Matteux
    Commented Dec 12, 2020 at 16:06
  • $\begingroup$ @brockmann Yes, it is a similar discussion, i didn't find it when i posted this one. Thank you. I will wait an upgrade from Blender or AMD $\endgroup$
    – Matteux
    Commented Dec 13, 2020 at 16:38
  • $\begingroup$ Or just downgrade one version. $\endgroup$
    – brockmann
    Commented Dec 13, 2020 at 16:39
  • $\begingroup$ Yes, I could downgrade, but I have bad memories about it. Even though I followed a highly rated guide on the AMD forum site, it caused some computer issues $\endgroup$
    – Matteux
    Commented Dec 13, 2020 at 16:43

1 Answer 1


After doing some research, it's seems to be some kind of problem with the newer AMD drivers (I have the same graphic card as you do). You can try to downgrade your RX drivers or wait for the developers to fix this bug.

  • $\begingroup$ Thanks, your support is helpful. I will wait for some updates from AMD or Blender, I tried some time ago downgrading the graphic drivers but it was a failure. For the moment your previous suggestion is enough for me to continue using Blender. Thank you so much $\endgroup$
    – Matteux
    Commented Dec 13, 2020 at 16:33

Not the answer you're looking for? Browse other questions tagged .