Blender newbie here. I used XYZ function in the add-ons to generate several meshes. Right now, the meshes are dense with black edges. How do I get these edges to be invisible when the object is not selected? For example, the UV sphere at the bottom looks lovely.

Picture of mesh with black lines


1 Answer 1


By default the meshes generated by this operator have Wireframe Display enabled in the viewport.

If you have already generated the mesh :

Go the object properties > Viewport Display > Uncheck Wireframe

enter image description here

If you just created the mesh using the operator, look into the lower left, you can expand a panel or use the shortcut F9, then look into the lower part of the panel. Uncheck "Show Wireframe".

enter image description here

Note 1 : This setting will be remembered in the current Blender session.

Note 2 : If you want to change the behaviour for all sessions, go to your blender install folder and then 2.** / scripts / addons / add_mesh_extra_objects and open add_mesh_3d_function_surface.py (use notepad)

Search for "AddXYZFunctionSurface" class in the file, go down to the lines

show_wire : BoolProperty(
        name="Show wireframe",
        description="Add the object’s wireframe over solid drawing"

500 to 504 in my file, and replace




Save the file, close it, open blender, the setting will be set to False by default.

  • 1
    $\begingroup$ Thank you! That worked perfectly. $\endgroup$
    – user67771
    Dec 9, 2020 at 19:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .