0
$\begingroup$

Original question:

I managed to model and rig my first character, and I'm now working on the animation, when I scrub through the keyframes in the timeline, the animation is working correctly, but when I press Play Animation - Spacebar, nothing happens, at all. I've tried a bunch of solutions already, but none of them seem to work.

Does anyone know how to fix this?

I have attached a screenshot of the scene and the .blend file below.

Current Scene

Blend File

Update: it seems to be a local issue with my Blender config/hardware, as other users are able to open the .blend file and getting playback. I've also tried rebinding the Play Animation - Spacebar again, but that didn't make any difference. Perhaps I will try installing a new and fresh Blender, see if that works, but I'm still wondering why I'm not getting playback in the first place? Any help is much appreciated as I lack the necessary experience to know where to look for a solution.

Update 2: After some great pointers by @Moonboots I now know the issue has something to do with my preferences. After installing 2.91 and opening the .blend file in that version with Factory Settings, the animation plays, success! But if I load my personal config in the freshly installed 2.91, the problem arises again. Now I would still like to find out, what in my original config file is causing this issue, and fix it, as I really feel at home in my config. I've added screenshots and of the comparison between my personal config and the Factory settings and a link to my personal config, maybe one of you can spot the issue?

Link to download my personal config

Animation Tab Interface Tab Viewport Tab Editing Tab System Tab File Paths

I've left out the tabs that are probably not the cause of this issue (Themes, Input, Navigation, Keymap, Addons, Save & Load and Lights). If you think this can also be the cause of this issue let me know and I will upload screenshots of those tabs too.

$\endgroup$
6
  • 1
    $\begingroup$ it works here, maybe check your Preferences > Keymap, in the search field > Name, type Play Animation, it should be Spacebar $\endgroup$ – moonboots Dec 8 '20 at 20:06
  • $\begingroup$ That's very strange, I have indeed remapped the spacebar key, but even when I press the actual play button in the GUI, nothing happens on my side. Thanks a lot for confirming it's something local at least! Ill try to rebind it to Space and see if that does any good. $\endgroup$ – Olivier Wierda Dec 8 '20 at 20:10
  • $\begingroup$ Rebound the Play Animation command to Spacebar again, but still, no playback sadly. $\endgroup$ – Olivier Wierda Dec 8 '20 at 20:22
  • 1
    $\begingroup$ Does it happen with any file? If it happens with this file only, just append the objects in a new one? But I guess you've already tried that... $\endgroup$ – moonboots Dec 9 '20 at 8:10
  • 1
    $\begingroup$ If you have a solution please add it as an answer. $\endgroup$ – batFINGER Dec 9 '20 at 15:33
0
$\begingroup$

Solution: It turns out the "Keymap" was actually the problem! I had disabled some parameters of the keymap, to give me a bit more space to assign keys myself. The specific parameter that was causing this issue was screen.animation_step > Timer > Timer 0. Restoring that to its original state, fixed the playback issue! Hope this helps for other people that have modified their keymaps!

Solution

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.