0
$\begingroup$

I have 4 objects produced in Blender in 4 separate files. 3 of them export with no problems the other one is enlarged slightly along the X and Y axes when exported to STL, the z axis measurement is not enlarged. The diameter of the object increases from 10.098mm to 10.744mm. I have the scene units scale set to 0.001 and the length to millimetres in the stl export menu. All of the files have the same settings, the Blender version is 2.91. The export scale is set to 1 and the scale units box is not ticked for all exports. A link to the problem file is below.

https://drive.google.com/file/d/1gh6vi6HwMrHBCEetUvR8QeKF2VjKMgln/view?usp=sharing

EDIT: The export to STL was not the problem, it was a mismatch between the location of the x and y vertices and the dimensions of the object. I don't know what caused the problem but the answer presented describes a workaround to correct the problem.

$\endgroup$
2
  • $\begingroup$ Does this answer your question? Scale settings for exporting to STL (for 3d printing) $\endgroup$ – brockmann Dec 7 '20 at 19:53
  • $\begingroup$ No the scale settings are the same for each of the objects and some are ok and others not. I've tried different cale options but then all of the objects are the wrong size. $\endgroup$ – Alastair Duncan Dec 7 '20 at 20:21
0
$\begingroup$

In the modeling tab and object mode, pressing n gives me the dimensions of the object and this is at odds with the location of the widest points on the x and y axes, which can be found by switching to edit mode and selecting the appropriate vertex. There seems to be a mismatch between the 2.

Location x = 10.098 times 2 gives me roughly 20.2 which is what I want. Dimension x = 21.5 which is definitely not right and it seems to be this dimension which is output to the stl file.

What I did to fix this: switch to object mode, select the object, press S to scale and then scaled by 0.939873418 for the X and Y axis and 1.0 for the Z axis and this corrected the dimension error. Inspecting the location of the widest point on the x axis shows that it has not moved.

Export of the STL shows the object now has the correct dimensions :-)

I've no idea what caused the problem in the first place.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.