1
$\begingroup$

I've got a plane with its Base Color set to a texture (let it be 100x100 pixels). When I scale this plane the texture gets scaled too, which is not what I want.

How do I make Blender not to scale this texture no matter how big the plain is? I don't want it to be scaled beyond 100%.

$\endgroup$
0

2 Answers 2

2
$\begingroup$

To complete Lemon's answer, if you scale your object in Object mode, you can't prevent the image to be scaled as well, but if you scale in Edit mode, you can keep the image texture at its current scale with the Correct Face Attributes option enabled (since 2.9):

enter image description here

$\endgroup$
2
  • $\begingroup$ It's strange, but I don't have this option. $\endgroup$
    – akond
    Commented Dec 7, 2020 at 15:17
  • $\begingroup$ Oh yes it's since 2.9 $\endgroup$
    – moonboots
    Commented Dec 7, 2020 at 15:18
1
$\begingroup$

Use "object" output from "texture coordinates" node:

enter image description here

Then to tune the texture position and scale, you can use the vector "mapping" node.

Also turn the image boundings to "clip" if you don't want it to repeat over the plane surface.


Alternatively, you can use another object as position, scale and rotation, as indicated here.


A link to the documentation.

Object

Uses an object as a source for coordinates. Often used with an empty, this is an easy way to place a small image at a given point on the object. This object can also be animated, to move a texture around or through a surface.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .