How do I assign same materials for objects created by array modifier? I created three houses by the modifier and want to assign a same color to their roof.

  • $\begingroup$ have you applied the modifier? $\endgroup$
    – moonboots
    Dec 6 '20 at 13:37
  • $\begingroup$ Yes. Thanks for your reaction. $\endgroup$
    – gogogogogo
    Dec 6 '20 at 13:39
  • $\begingroup$ So by default, if you've given a material to the roof of the original object, all the roofs should have the same material $\endgroup$
    – moonboots
    Dec 6 '20 at 13:42
  • $\begingroup$ If you're trying to assign the material AFTER you've applied the modifier, select all the roofs and make sure the one that has the material is the active object. (by selecting it last e.g.) Then, press Ctrl + L and select Materials. $\endgroup$
    – michaelh
    Dec 6 '20 at 13:47
  • $\begingroup$ if you didn't give any material to the original object, a thing you can try is select all the objects (if they are separate), switch to Edit mode, select the roof of one of the houses and press Ctrl G > Normals (or test the other options), it may help to automatically select all the other roofs if they are a bit tilted $\endgroup$
    – moonboots
    Dec 6 '20 at 13:56

If your house base model is a continuous mesh (no loose parts), once the modifier is applied, go into edit mode, select everything and press P > By Loose Parts.

Go back into object mode with TAB.

With everything still selected, Right click > Set Origin > To geometry.

Press CTRL+ L > Object Data. Now when you modify one object's materials, they will all update.

In the end, while everything is still selected, go to Object > Relations > Make Single User > Object & Data and then you will be able to tweak each individual house separately.

Obviously it is better to do it before applying the modifier to avoid any of this.

PS, next time please take more time to write your question so there is less back and forth in the comments :)

  • $\begingroup$ Thanks for your solution and advice. $\endgroup$
    – gogogogogo
    Dec 8 '20 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.