14
$\begingroup$

I don't know why but now, when i go in material preview or rendered (in solid mode it works fine), my object is entirely gray, or invisible idk, because it has the same color of the background.

I've been working for days on this project without having this issue, it suddenly showed up.

I tried opening other old projects and suddenly they all do the same so i guess it is some blender program setting that applies for all the projects, but idk how it happened cuz i didn't change anything :/, anyone got any tips? enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Are you using an AMD GPU with driver version >20.11.1? $\endgroup$ – Robert Gützkow Dec 6 '20 at 10:56
  • $\begingroup$ Yeah, i just realized that since the problem has appeared, the only thing i changed is that i updated the amd drivers, i also just read a discussion that says that it is the problem. :/ $\endgroup$ – Pino Vanta Dec 6 '20 at 11:02
12
$\begingroup$

Update: Blender 2.92.0, 2.91.1 and 2.83.11 will contain workarounds for the missing / incorrectly rendered surfaces of mesh, curves and metaballs as well as the incorrectly rendered wireframes caused by bugs in the graphics driver.


The graphics driver version Adrenalin 2020 Edition 20.11.2 and later appear to cause issues for several users, as reported in T82856 and related tickets. Installing a previous driver version should solve these problems until the bug in the driver is fixed or Blender provides a workaround for the problem.

$\endgroup$
3
  • $\begingroup$ Adrenalin 2020 Edition 20.9.2 fixed this issue for me $\endgroup$ – tantangula Dec 15 '20 at 3:55
  • $\begingroup$ Blender 2.83.11 and 2.91.1 will also have these work around so added. $\endgroup$ – J. Bakker Jan 15 at 18:13
  • $\begingroup$ @J.Bakker Thanks. I've updated the answer. $\endgroup$ – Robert Gützkow Jan 15 at 18:15
9
$\begingroup$

As mentioned in the bug report T82856 a temporary solution is to enable High Quality Normals under the Performance section in the Rendering tab on the right in a default Blender layout.

Rendering tab

$\endgroup$
2
$\begingroup$

Just roll back to the previous version of your AMD driver. Click on the windows icon Search for Device Manager Dropdown the Display Adapters option click on AMD driver Under the Driver's Tab Roll Back Driver Option And now the Blender is good again.

$\endgroup$
1
$\begingroup$

Blender Version 2.91.2 addresses some of the problems with AMD cards

https://developer.blender.org/T83216

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.