0
$\begingroup$

Blender was working fine until recently (I can't pin point what happened). I have not knowingly changed any settings in Blender or on my PC in general. I've been working with Blender daily and hadn't noticed the change since most of what I was doing was in Cycles Render View, which does seem to work.

Here's the problem. Doesn't matter if it's a file I open or a default object on a fresh file. In Object mode, if I add any object (example monkey), then switch to wire frame, I get an outline of the object only, no wire frame. Solid view seems to show correctly. Material Preview only shows a filled outline, the fill color is the same as the grid color, but applying a color does not make any difference. Render View EEVEE shows a filled outline, not a render, and the fill color disappears as I rotate the object. If I switch to Cycles, it seems to be ok.

I was using Blender 2.90, and hoped that switching to 2.91 would resolve, but it's exactly the same. I also tried going back to 2.8 and got the same result. I then looked at my graphics card RX 580 which recently did an update...I reverted back to the previous version, but to no avail.

I'm out of ideas, and cannot figure out if this a Blender issue, a hardware/software issue....or if I inadvertently clicked something. I've looked through Blender settings repeatedly but can't see what could be wrong.

I did see a post here from another user who is having the exact same issue, and he/she uploaded a youtube video showing their issue. I would have preferred to comment on theirs, but this forum doesn't let me, so I had to load my own questions. [UPDATE Dec 4-2020] I did a system restore back 1 month (to ensure no new updates were present), tested and Blender was working fine (V2.90). I began re-installing updates one at a time and test after each. Summary of results - All Windows updates installed to current, Blender works fine. Radeon updates - v20.9.2 (driver v27.20.12031.1000), Blender works without issue. Radeon update 20.11.2 & 20.11.3, Blender is broken.

$\endgroup$
6
  • $\begingroup$ Yes there are the graphic card driver discussions drifting about. You did look at the overlay settings for particular objects and classes of objects in the 3D Viewport Window? I had a problem that I did not pursue strongly with lattices. It was in the overlay [extras] category. $\endgroup$ – atomicbezierslinger Dec 3 '20 at 22:55
  • $\begingroup$ I've seen a lot of related complaints on this site recently, some specific to the RX 580, others with newer cards such as the RTX 3000 series. I'm beginning to thing it must be the result of some driver update that was pushed out in timing with the new hardware. Some have had success using 2.92 alpha, but it doesn't always work. $\endgroup$ – Christopher Bennett Dec 3 '20 at 22:57
  • $\begingroup$ @ atomicbezierslinger I'm using factory default settings (with the exception of changing to OpenCL). No addons are active, and the issue is present on default objects on a new file. I tried looking at the overlays, but don't see any problems from there, and changing any settings does not resolve the issue. $\endgroup$ – Joe Dec 3 '20 at 23:17
  • $\begingroup$ "Not knowingly changed", could it mean that the OS (windows?) did an automatic update ? $\endgroup$ – susu Dec 3 '20 at 23:18
  • $\begingroup$ @susu Yes, as a matter of fact, Windows did a large update last week. I considered that, but would have thought there to be way more noise about this issue if that were the case. I suppose I can't rule it out, but I don't even know where to begin if that's the case. $\endgroup$ – Joe Dec 3 '20 at 23:21
2
$\begingroup$

Started having the same problem just after a Radeon update[I think 20.11.1] (AMD RX580 8gb), GPU viewport rendering is broken(was using portable Blender folder, tried installing updated Blender and still no fix). After some googling found some people were having similar problems and decided to leave it for a couple of weeks in case of a fix-patch.
No update patch yet but I tried switching to "High Quality Normals" and it totally worked for me!

TEMPORARY FIX: Render Properties > Performance > High Quality

Hope this can help others too.

$\endgroup$
1
$\begingroup$

I have the same exact issue as you and I actually posted about it a few hours back. During that time I was just fiddling around with the render settings and I discovered that (in Eevee) going to Performance > High Quality normals and turning "High Quality Normals" on fixed the issue for me. Hope if works for you too!

$\endgroup$
1
  • $\begingroup$ I use Cycles render and don't see an option for High Quality Normals. But thanks for taking the time to send your find, glad it works for you. $\endgroup$ – Joe Dec 21 '20 at 19:15
1
$\begingroup$

Graphics card update is cause of issue in viewport.

  • Radeon updates - v20.9.2 (driver v27.20.12031.1000), Blender works without issue.
  • Radeon update 20.11.2 & 20.11.3, Blender is broken.
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.