0
$\begingroup$

I was trying to extrude the edges in the z axis using the extrude tool from the toolbar and not the shortcut key. The first time I extruded the edges it was fine. But the second time I tried to extrude the edges I couldn't do it in the z axis. It was allowing me only in the x axis. I was wondering what have I done wrong.

enter image description here

$\endgroup$
1
  • $\begingroup$ I got the same problem, just fix it by appling all transforms. $\endgroup$
    – jmbenck
    Jul 1 at 4:17
2
$\begingroup$

(Blender 2.92) Wow. This is a curious one. I think this is what's going on..

enter image description here

You're extruding edges, along their median (actually mean) Normal, which is to say the mean normal of their vertices. In the first extrusion, all the vertex normals have a -Z component, the X's and Y's cancel, so the mean normal is -Z. In the second extrusion, none of the vertex normals has a Z component, the other components cancel, and so the Normal is 0. Blender seems to gives an arbitrary vector for this?

TL;DR

Fill the hole and extrude a face, which has a normal, or use the XYZ setting for the tool.

The behaviour has changed in version 2.93

$\endgroup$
3
  • $\begingroup$ I don't see the problem. Maybe it's just incorrect use? I don't have to create a face. $\endgroup$ Jul 1 at 8:28
  • $\begingroup$ @Gordon Thanks! This has been fixed in 293 .. I wonder how, though? .. i.e. how Blender decides what the mean normal of a collection of vertices is, when the vector sum is 0? I suspect it must be doing what this post suggests you do manually. Although, come to think of it, I don't know how blender defines the normal of an arbitrary ngon, either, reasonably economically. If I knew where to look.. :) $\endgroup$ Jul 1 at 8:44
  • $\begingroup$ Oh yeah I see it changed, just tried it in 2.83.5, I've edited my answer to give a full explanation on how to work with the tool to achieve what he wants... still no need for a face, but you mention the XYZ setting already ;) But I guess the answer that jmbenck gives is based on 2.93 and using it wrong - because in the old version, applying a transformation wouldn't help, he would still be facing the same problem that you explain in your answer: no Z component. $\endgroup$ Jul 1 at 8:59
1
$\begingroup$

EDIT: As @RobinBetts pointed out, the behaviour changed in Blender 2.93 (see below), so here's what to do if you have an earlier version:

If you simply want to constrain the extrude to the global Z axis (not some custom orientation), you can simply switch the Extrude Region and Move tool from using the Normal to the XYZ axis with the button at the top. Or if you keep the Normal option, just grab the circle instead of the Plus. This let's you extrude freely without constraining the direction. If you now hit Z, the direction gets constrained to the Z axis just like it does when you're moving, rotating or scaling things.

extrude free

And this is how it works in 2.93 and above: After the first extrude, you have the option to further move the extruded part by grabbing the arrow, or do another extrude by grabbing the plus.

First extrude:

first extrusion

Now if you want to move it further down without extrusion, use the arrow - if you hover over it, it becomes white:

move

But if you want to do another extrusion, hover your mouse over the Plus to grab it and it shows in white:

second extrude

Just pull it down like you did the first time and you have another extrusion:

result

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.