0
$\begingroup$

I am following Blender Guru's mars tutorial and making a surface with rocks using two particle systems. One using bigger rocks and one using smaller rocks, both are collections of objects. The render result was fine at first but as I altered the rocks in the collection and made other changers, the smaller rocks disappear in the render. In the 3D viewport rendered view, it still looks fine, like this: 3D viewport rendered view

but in the rendered result, there is like only 10% of the small rocks rendered. (Big rocks hided and material was adjusted to shrink the file size) render result (JPEG)

Does it has something to do with having two particle systems on one mesh? Because the plane in the back with only one particle system looks fine.

Here is the file:

$\endgroup$
4
  • $\begingroup$ make sure that the camera icon is enabled on the top of the Particle panel $\endgroup$ – moonboots Dec 3 '20 at 8:12
  • $\begingroup$ Yes it is, but it seems that only one of them is rendered... $\endgroup$ – Franc Dec 3 '20 at 8:18
  • $\begingroup$ It seems like some of your rocks visibility is disabled in the Outliner, is it your problem here? Click on the funnel icon and click on the camera icon to display the Disable in Renders option $\endgroup$ – moonboots Dec 3 '20 at 8:31
  • $\begingroup$ By the "funnel icon" do you mean the green one? and "camera icon" is it the render properties? $\endgroup$ – Franc Dec 3 '20 at 8:48
1
$\begingroup$

It seems like some of your rock visibilities are disabled in the Outliner. Click on the funnel icon and click on the camera icon to display the Disable in Renders option:

enter image description here

$\endgroup$
1
  • $\begingroup$ I think that's it! Thanks! $\endgroup$ – Franc Dec 3 '20 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.