0
$\begingroup$

I just downloaded Blender 2.83 LTS version and Blender 2.91 and encountered a very weird problem.

When I open Blender and add any object, whether it is any mesh or I import any file, it doesn't show the Wireframe in wireframe mode, and also it doesn't show anything in material preview mode.

It shows the object in rendered mode and that is also only if I switch my render mode from Eevee to Cycles. Everything is visible only in the solid mode in every render setting.

When I am using Blender on my laptop with some old 2 core Intel processor and 2GB Nvidia Graphics card, everything is working perfectly fine but my laptop is not powerful enough to work on.

I checked everywhere on the internet for similar problems but no one posted the solution related to this.

This is how it looks like https://www.youtube.com/watch?v=YtpySO4vK_I.

I changed and tried all systems setting in preferences and switched Blender versions but nothing worked. Moreover, it doesn't show the vertices in vertex paint mode also. Please help

My configuration is:

  • 1950X processor
  • RX 580 graphics
  • and Windows 10 Pro
$\endgroup$
7
  • $\begingroup$ could you share your file please? >blend-exchange.giantcowfilms.com $\endgroup$
    – ETHAN DAY
    Dec 2 '20 at 15:51
  • $\begingroup$ What file do you need? I mean I am adding any mesh from blender itself .. UV sphere and all ... but the problem is the same .. first I tried to open the blend from external packed from my laptop .. it was giving me the issue ... and then after spending time when I opened the project and added the meshes from blender itself it was giving me the same problem but again I tried in my laptop everything was working fine as before. $\endgroup$
    – Abcd xyz
    Dec 2 '20 at 16:02
  • $\begingroup$ Did you select OpenCL instead of CUDA in your render settings? (Difference is Nvidia vs AMD card - use CUDA for Nvidia and OpenCL for AMD) $\endgroup$ Dec 2 '20 at 16:04
  • $\begingroup$ Yes, I truned that to OpenCL ... as it doesn't show the cuda option for my graphics ... I recorded in the video to show that too but because it opens in the new tab .. so i think that xbox gaming recorder didnt take it ... i tried to out only on graphics then only on CPU and then on both ... but nothing worked ... I just updated my graphics card today .. if it may be a problem? Idk $\endgroup$
    – Abcd xyz
    Dec 2 '20 at 16:17
  • $\begingroup$ Have you updated all your GPU drivers to the latest version? $\endgroup$ Dec 2 '20 at 16:29
1
$\begingroup$

If you turn on High Quality Normals under Performance in Eevee it will fix most of the issues but not all, the Wireframe will still be an issue but at least you won't get that black shadow object.

I bet you have an AMD graphics card, the drivers that work for me are 20.9.2 (late September)

$\endgroup$
0
$\begingroup$

I just got reply from developers.

They said the issue is with the new update of the graphics card, so they informed me to degrade the version on my graphics card.

Thank you all for taking time to answer me.

$\endgroup$
1
  • $\begingroup$ Where did you get a reply? Could you link it here? Can you elaborate on what you mean by "degrade the version of my graphics card". Do you mean to degrade the graphics card driver or do you really need to switch to older hardware? $\endgroup$ Jan 22 at 8:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.