1
$\begingroup$

Sometimes, when I think I'm in Edit Mode but I'm actually in Object Mode, I'll hit Ctrl-Tab, and I get switched into Weight Paint mode. Is there a hotkey that will reliably take me back to Object Mode? Hitting Ctrl-Tab again seems to work some of the time, but other times it does nothing, and I can't see any pattern to whether it'll work or not.

$\endgroup$
1
  • 1
    $\begingroup$ Actually this is not how it works for me.... I always get the pie menu where I can select which mode I want to change to.when I hit CTRL+TAB. But whatever mode I'm in, TAB enters Edit Mode and switches back to the previous mode. $\endgroup$ Dec 2, 2020 at 8:29

1 Answer 1

1
$\begingroup$

I caught the pattern.

Ctrl + Tab works if you was in Object Mode then you go to Weight Paint Mode and with doing nothing you're hitting Ctrl + Tab again.

But if after Object Mode you switched to Weight Paint Mode and then pressed Tab (in order to switch to Edit Mode) then you can't switch to Object Mode using Ctrl + Tab

I solved this issue just adding a new keymap in settings, see screenshot. Hope it'll help you somehow.

enter image description here

$\endgroup$
1
  • $\begingroup$ That was just what I needed! It's a shame it took me so long to see it. For anyone who sees this and is clueless about modifying key bindings, here's a step-by-step: From the main menu, Edit > Preferences. In the preferences window that appears, select Keymap on the left, as shown. In the drill-down menu on the right, expand 3D View > Weight Paint, and there will be a button at the bottom of the list to add a new entry. Do that, and make it look like the picture, then you're done! $\endgroup$ Oct 1, 2023 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .