I'm trying to render a texture that uses a Principled BSDF shader using Eevee, however nothing is shown on the render output

This is what I'm getting:

I initially thought this might have something to do with my texture, so I used an RGB input and got exactly the same problem:

If I remove the Principled BSDF and link the picture direct to the Material Output it works fine:

This also applies to RGB inputs as well.

I've tried other shaders, and I'm having the exact same problems.

Oddly if I use the Cycles engine, the Principled BSDF (as well as all the other shaders) works fine:

What I've done to try and solve the problem:

  • loaded factory settings
  • selected the "repair" option on the Blender installer
  • reinstalled Blender
  • upgraded Blender to the latest version
  • updated Windows and all my drivers to the latest version (including the GPU)
  • tampered around with some of the settings (admittedly I don't know what I'm doing with most of them, so I could easily have missed it)

Could anyone please offer some help? It's been a few days and I'm getting a bit desparate.

  • 1
    $\begingroup$ could you please pack your image and share your file? blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Commented Dec 1, 2020 at 13:40
  • $\begingroup$ @moonboots Here is my blend file blend-exchange.giantcowfilms.com/b/KlOxS9v1 I'mn not exactly sure how to pack it. Here is the texture via Drive drive.google.com/file/d/1TAVvNUXi0eWqvoge5CpTwYFxU8iOIzZx/… I hope that will do $\endgroup$
    – Xantium
    Commented Dec 1, 2020 at 13:51
  • $\begingroup$ it works fine here, with Eevee or Cycles, so I don't know, I hope someone has an idea :(( $\endgroup$
    – moonboots
    Commented Dec 1, 2020 at 13:58
  • 1
    $\begingroup$ @moonboots I also had some files sent that had textures and they didn't show up either. Could it be a broken GPU? As I understand Eevee is GPU based. $\endgroup$
    – Xantium
    Commented Dec 1, 2020 at 14:08
  • 1
    $\begingroup$ oh ok, nice you've found the solution $\endgroup$
    – moonboots
    Commented Dec 1, 2020 at 14:48

1 Answer 1


OK I eventually fixed it.

I ran debug mode and got the exact same error as on this thread posted this morning:


This is what they said:

Next time, please follow the submission template and attach the debug log and system info as file.

Please try to install a previous version of the graphics driver prior to Adrenalin 2020 Edition 20.11.2 Optional, 27.20.14501.18003 and report back if this resolves the issue.

I downgraded my graphics to 20.11.1 and it worked fine.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .