0
$\begingroup$

I extruded a curve and the result has the right geometry but the shadows appear wrongly on the flat surface. How/what do I have to adjust to correct it? I already checked for duplicate vertices.

enter image description here

$\endgroup$
2
1
$\begingroup$

If you're talking about this shape, increase its V resolution:

enter image description here

$\endgroup$
1
  • $\begingroup$ The answer by moonboots is correct, it's depending on the curve's resolution. I opened the file and found that actually both U and V resolutions have to be cranked up high to look like something you can achieve with a mesh and Auto Smooth. Actually I had to go beyond 200 as V resolution before it began to look anything like a slightly beveled edge. On U resolution I had to set it manually to over 500 (because the slider stops at 64). So although this works, for really sharp or just slightly beveled edges I'll post an optional answer. $\endgroup$ – Gordon Brinkmann Dec 2 '20 at 7:59
1
$\begingroup$

Since the Auto Smooth option is not available for curves at the moment, you can do the following to get sharp(er) edges with a smoothed surface:

  1. Use the EdgeSplit Modifier to get sharp, unbeveled edges. The default settings should be fine, but you can set the Edge Angle to something higher close to 90°, since you only want to bevel the border edges.
  2. For beveled edges, use the Bevel Modifier, set Width Type > Percent (that seemed to be the only width type where you don't need a high number of segments, but might depend on the curve's U/V resolution). Set values for Percent and Segments according to your liking.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.