0
$\begingroup$

I started using blender this year in another computer and all worked nicely until I migrated to a new PC.

I started making a room for a new scene, then I noticed it doesn't render Image of the room

This is how my render Shows

Then I started looking on old work that used to render correctly, for example this sword: For example this blade

Now this is how the render looks in my new PC

As you can see, the object indeed does have an appearance in my render but does not show it's body and properties.

Things/tutorials I've tried: 1-Reset blender to it's factory default

2- https://blender.stackexchange.com/questions/964/object-not-visible-in-render#:~:text=In%20object%20mode%20press%20W,objects%20visible%20in%20the%20render.&text=If%20there%20are%20objects%20that,This%20toggles%20camera%20visibility

3-https://blender.stackexchange.com/questions/53632/render-result-is-completely-blank

Lastly 4-https://blender.stackexchange.com/questions/67490/why-does-my-object-not-show-up

Nothing seems to solve my problem.

$\endgroup$
6
  • $\begingroup$ It looks like it could be GPU or driver related. What kind of GPU does your (new) computer have? $\endgroup$ – Christopher Bennett Nov 28 '20 at 22:08
  • $\begingroup$ @ChristopherBennett I thought of that but I didn't think it was going to be a problem I have a AMD Radeon HD 7950 I'm using the same GPU from my old computer (which it worked before) And installed the latest drivers from Amd Software I've also played some games and got zero problems. $\endgroup$ – Ricardo Yau Nov 28 '20 at 22:47
  • $\begingroup$ Are you using the same version of blender? $\endgroup$ – Christopher Bennett Nov 28 '20 at 22:56
  • $\begingroup$ @ChristopherBennett No, my blender just got updated 2 days ago to the latest version, just about when I changed computer, maybe I could try getting 2.8 or just 2.9 $\endgroup$ – Ricardo Yau Nov 28 '20 at 22:59
  • $\begingroup$ I only ask becasue 2.8+ comes with a new set of GPU requirements that weren't there in 2.79 and below. Have a look here to see if yours is supported. If not, use version 2.79 - code.blender.org/2019/04/supported-gpus-in-blender-2-80 $\endgroup$ – Christopher Bennett Nov 28 '20 at 23:23
1
$\begingroup$

I've found my problem and solved it, at least for my specific graphics card (AMD radeon hd 7950) I had updated my drivers for the latest version (Adrenalin 2020 Edition 20.11.2, which is optional) for some reason Blender has some problems with that version, so I decided to downgrade my version to Adrenalin 2020 Edition 20.9.1 which solved every problem. Now I can render in every Render Engine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.