1
$\begingroup$

I am new to blender and after learning the basics I tried to model a spoon myself. When I was in render view mode I had this view.

in render view mode

But when I rendered it, the result had a different view.

enter image description here

Can someone help?

Sorry if I left some necessary details. Pardon me for being a beginner.

Edit Here is the blend file

$\endgroup$
7
  • $\begingroup$ My guess is you "set" the camera position by zooming while in camera perspective. When you are in camera perspective, zooming in doesn't move the camera forwards, it just makes the image bigger (if you get my meaning - the camera perspective shows a 2D image of your 3D scene). Pan out of camera perspective mode, move your view to the right location, then set the camera position again with Ctrl + Alt + Num0. The area that will be rendered will be surrounded by a black frame. If you can't see the frame, zoom out (scroll with mouse) until you can see it. $\endgroup$ Commented Nov 28, 2020 at 1:32
  • $\begingroup$ @ChristopherBennett doesn't locking camera to view solve this? Also I am using a laptop so I don't have a numberpad is there an alternative to that too? $\endgroup$
    – nsrCodes
    Commented Nov 28, 2020 at 1:34
  • $\begingroup$ I'm not too sure about locking camera to view, because I rarely use it. If you want Numpad control, go to Preferences > Input and check the "Emulate Numpad" checkbox at the top - this will make the regular number buttons act the same as the Numpad ones. $\endgroup$ Commented Nov 28, 2020 at 1:36
  • $\begingroup$ @ChristopherBennett I understand what you mean, at first even I thought that was the problem. Then I opened two adjacent tabs with one in render mode and the other in solid mode with view on camera, whenever I could see the camera move in the other tab too. $\endgroup$
    – nsrCodes
    Commented Nov 28, 2020 at 1:37
  • $\begingroup$ Yeah, I get that, but I think when you have lock camera to view enabled, you should see a highlighted area that the camera is "seeing" - ibb.co/ynQvTk4 $\endgroup$ Commented Nov 28, 2020 at 1:39

2 Answers 2

1
$\begingroup$

Start by making sure you have that "Emulate Numpad" enabled. Then, turn off "Lock camera to view" and press 5 twice. This should put you into ortho view, then back to 3D navigation. When I did this, you can see where the camera is relative to the object.

Cam1

From here, move your viewport until it's at the desired distance and angle and press Ctrl + Alt + 0 - this will set the camera to your view. When I did this, it appeared waaaaay zoomed in, so scroll out with the mouse wheel until you see the box:

Cam2

However, when I placed it in a spot that looked "correct" relative to your reference photo, you can see where the camera is. I'm not sure why this is happening, other than the object(s) you have are very small. Adding a new camera had the same effect. It might not be a problem at all though, because the render comes out exactly like what is shown in the box - at the very worst, you could scale up the objects if necessary.

Cam3

$\endgroup$
1
  • $\begingroup$ Just press the Home key to show the full camera view. $\endgroup$
    – susu
    Commented Nov 28, 2020 at 3:04
2
$\begingroup$

Even though you have the camera view and have lock camera to view, the edges of the camera are not visible on the first image, hence you are looking at a zoomed in window that does not represent the full camera view.

Press the Home key to show the camera view.

enter image description here

$\endgroup$
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .