0
$\begingroup$

So I turned on rigid body physics and cannot for the life of me figure out why my objects are just floating around now. I didn't have this problem at the start of this scene.

My gravity is still enabled. First thing I checked.

Next I thought it might be force fields. I made a few at some point trying to understand them more and have since made sure they are all deleted yet I'm still having force field like behaviors. The donuts aren't just floating up, some are floating in random paths.

I also have noticed if I change the rigid bodies to be mesh rather than convex hull it is causing my machine to freeze up which is odd for this simple of a scene on my machine.

Any ideas?

Blend File:

$\endgroup$
2
  • $\begingroup$ In Scene Properties > Rigid Body World > Field Weights you have gravity turned down to 0. Also, 400000 faces isn't that simple of a scene, at least not for Blender's physics engine $\endgroup$ – wilks Nov 27 '20 at 21:59
  • $\begingroup$ @wilks yeah I turned that to 0 during the process of trying to figure out what was happening. I just turned it back to 1 and it had no effect. I also recreated the scene and the new project isn't giving my computer any problems, running the simulation in real-time without any problems. Still trying to get it to simulate how I want but I'm super curious where I went wrong the first time. $\endgroup$ – Jboogsthethug Nov 28 '20 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.