1
$\begingroup$

I'm trying to import into Blender 2.9 some .fbx models exported from a 3D software called Noesis. The issue I'm facing is that the models, once in Blender, look somewhat covered by a glossy/metallic surface, both in solid mode view and in material preview. This is what I mean:

enter image description here

while this is what I would expect/like:

enter image description here

This second picture is done removing the material assigned to the object, to understand if the issue was related to the material itself, and indeed it looks so.

This last picture shows (on the left) the object as shown on Noesis (and how I'd like it to be), and on the right how it looks on Blender. As you can see, that glossy feel is there also in material view.

enter image description here

I tried importing the object in an online FBX viewer, and it looks glossy too, so I'd say it's not a Blender problem. Do you know what it could be, and how I could fix that? (assuming that I can't edit any parameter during the export on Noesis) thank you

blender file:

$\endgroup$
2

1 Answer 1

2
$\begingroup$

Check the Material Viewport Display, the Metallic value is 1, bring it back to 0:

enter image description here

Also, the material is 100% metallic, bring the value to 0 if you don't want any metallic effect:

enter image description here

$\endgroup$
6
  • $\begingroup$ I tried that (also tried unchecking "custom normals" while importing FBX) but it didn't make any difference except showing the mesh with flat shading) $\endgroup$ Nov 28, 2020 at 13:39
  • $\begingroup$ Yes my bad, I've edited, I hope it helps? $\endgroup$
    – moonboots
    Nov 28, 2020 at 13:48
  • $\begingroup$ yes, totally helped! many thanks. Do you know a way to do a batch edit for all materials? $\endgroup$ Nov 28, 2020 at 14:02
  • $\begingroup$ no, maybe with code but I don't know anything about coding ;) $\endgroup$
    – moonboots
    Nov 28, 2020 at 14:09
  • $\begingroup$ this: import bpy for mat in bpy.data.materials: if not mat.use_nodes: mat.metallic = 0 mat.specular_intensity = 0 continue for n in mat.node_tree.nodes: if n.type == 'BSDF_PRINCIPLED': n.inputs["Metallic"].default_value = 0 n.inputs["Specular"].default_value = 0 $\endgroup$ Nov 28, 2020 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .