1
$\begingroup$

I'm doing a more anime style animation and I'm using vroid to help with anime characters but it uses transparent materials for the eyebrows and eyelashes. Obviously if I'm using vroid for anime characters, I'm going to use freestyle, or the other method I forget its name, but it sees them has a mesh and no tutorial I look at mentions how to solve this problem, which is odd since you know anime has outlines.

So I need help figuring out how to make freestyle ignore or go through them or if theirs an add-on that does that. Please use pictures or video as I'm still new to blender.

Also, I'm going to use the eevee engine.

This is what it looks like when I render it.

enter image description here

$\endgroup$

1 Answer 1

5
$\begingroup$

You can put the object you don't want to have freestyle lines in a separate second collection.

Then you can make a second Freestyle Line Set, and as the Collection choose the second collection and click the button Exclusive next to it.

Now all the object in that collection will be ignored when rendering freestyle lines.

enter image description here

$\endgroup$
3
  • $\begingroup$ Will that work on meshes that are weight painted, shape key, and attached to a mesh. If it helps. Here's an image drive.google.com/file/d/1ndPEncFyKz85n1X9qyqh4FOMd_xzjoUE/…. I don't know how to show images. $\endgroup$ Nov 27, 2020 at 2:45
  • $\begingroup$ It will work for any separate object(s). So if an eyebrow is an object that you can move by itself, it works. But it the selected Edge Types are also relevant. I might have oversimplified things. The exact settings might require some figuring out (I'll try to look into it later when i have more time.) $\endgroup$ Nov 27, 2020 at 4:41
  • $\begingroup$ This does not actually work. The render looks exactly the same as without these steps. $\endgroup$ Jul 10, 2023 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .