When I attempt to move the rig of the character the clothes overlap for some reason. How can I fix this? I've increased quality steps, applied scale and changed soft body and cloth settings. Would I need to sculpt the cloth?enter image description here


1 Answer 1


I'm not a cloth expert but as I told you I think this tutorial by Aneesh Arts gives a series of good tricks.

The first thing I would say is that your gown and pants are rather high-poly and it doesn't help to easily work, you should do a low-poly version and give it a Subdivision Surface modifier.

That said I was able to quickly improve your problem with these 2 solutions:

  • First, move a bit the vertices of the bottom of the gown with the Proportional Editing enabled. You can even create a new shapekey so that the topology only moves when necessary:

enter image description here

  • Find and display the deforming bones in the armature layers:

enter image description here

  • Select the armature, then shift shelect the pants, switch to Weight Paint mode, check each bone and use Blend > Mix or Subtract to increase or decrease their influence. Then do the same for the gown, until there is no clothes overlapping:

enter image description here

  • At the end you should be able to have a good result:

enter image description here

There is another method that may help, it is to give your clothes a Mesh Deform modifier as I explained here, you could try to associate it with cloth simulation...

  • $\begingroup$ Yes that makes a big difference. Thank you! How could I make the clothes low poly? $\endgroup$ Commented Nov 27, 2020 at 14:28
  • $\begingroup$ You need to retopologize it, i.e. create a second mesh and stick to the original one with the snapping option, look at the leg mesh for example, it's much simpler, you could even have less faces $\endgroup$
    – moonboots
    Commented Nov 27, 2020 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .