0
$\begingroup$

I've been trying to bake the procedural shadows made by this shader, down to a single BaseColor texture, and with success, but there is a weird problem with asymmetrical baking, in the viewport it is okay, but in the bake there is too much shadow in some places: shader

Viewport :

Viewport

Baked Texture : Baked Texture

As you can see the left eye has more shadow than the right one, any ideas why this is happening and maybe how to solve it?

Thanks in advance, Olivier

$\endgroup$
7
  • $\begingroup$ Are you using non-directional (no sun) lights? $\endgroup$ – Frederik Steinmetz Nov 26 '20 at 10:46
  • $\begingroup$ Yes, I use the light coming from the background as a light source. There are no other lights in the scene. $\endgroup$ – Olivier Wierda Nov 26 '20 at 13:58
  • $\begingroup$ which map are you baking? This setup should go into emit $\endgroup$ – Frederik Steinmetz Nov 26 '20 at 15:26
  • $\begingroup$ I think it was on Combined Render pass and I was trying to bake it as a BaseColor / Diffuse map. Anyhow, I solved the problem with Photoshop, but still wondering why it went wrong in the 1st place! $\endgroup$ – Olivier Wierda Nov 26 '20 at 22:46
  • $\begingroup$ Have you enabled only this object for render? For example, is there an eyeball that is hidden but will get rendered? $\endgroup$ – Blunder Nov 27 '20 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.