0
$\begingroup$

I need help. I model a car bonnet and overall everything is good, but there is a small weird shading that I don't know how to fix. Auto-Smooth is on, a bonnet line is marked as sharp, and I tried Recalculate Normals, but nothing worked. Maybe I don't understand something. Thanks in advance. Here is a link to a file: and here are a few images: enter image description here

enter image description here

enter image description here

$\endgroup$
5
  • $\begingroup$ could you please share your file (at least this part)? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Nov 24 '20 at 16:36
  • $\begingroup$ I shared my file. $\endgroup$ – ALEXander Nov 24 '20 at 19:20
  • $\begingroup$ you need to copy paste the link here ;) $\endgroup$ – moonboots Nov 24 '20 at 19:21
  • $\begingroup$ Understood, wait=) $\endgroup$ – ALEXander Nov 24 '20 at 19:21
  • $\begingroup$ Pasted into my post. $\endgroup$ – ALEXander Nov 24 '20 at 19:24
1
$\begingroup$

Just adding something else to Moonboots suggestion:

After dissolving the 2 edges to even out the spacing there is still a little bad shading going on (see first image below) which if necessary, can be fixed by using the Clear Custom Split Normals Data option.

Object Data Properties > Geometry Data > Clear Custom Split Normals Data.

enter image description here

enter image description here

How did you arrive at having Custom Split Normals Data? When you selected the edges to Mark Sharp I think you must have done the following: with edges selected > Mesh > Normals > Split. This results in the Auto Smooth Angle being greyed out.

Instead of using the above method to split the normals of the selected edges use the more usual : selectect the edges > Edge > Mark Sharp.

I don't really understand the difference between the two methods but just thought it worth mentioning.

$\endgroup$
1
  • $\begingroup$ Thank You so much!!! Your answer really helped me, because moonboots helped me a little bit, but the problem didn't solve. "How did you arrive at having Custom Split Normals Data?" - I don't know how it happened, most likely random clicking) $\endgroup$ – ALEXander Nov 24 '20 at 21:44
1
$\begingroup$

You need to dissolve these 2 edges, they tend to flatten your faces:

enter image description here

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank You) That worked. $\endgroup$ – ALEXander Nov 24 '20 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.