2
$\begingroup$

i imported a open vdv file and render it but I looks blocky and has weird lines in the end render I didn't change any settings from the volume, what can I do to make it, well not look like garbage the image

$\endgroup$
6
  • $\begingroup$ where is the vdb from? What fields does it have? $\endgroup$
    – Timaroberts
    Nov 23 '20 at 21:32
  • $\begingroup$ what do you mean with fields ? I got the file from here jangafx.com/software/embergen/download/free-vdb-animations $\endgroup$
    – K Tech
    Nov 23 '20 at 21:47
  • $\begingroup$ the gasoline explosion is the one I picked I saw a lot of tutorial using the exact same and in their videos it always looked great but not in my case im using 2.90.1 by the way $\endgroup$
    – K Tech
    Nov 23 '20 at 21:50
  • $\begingroup$ it has density flames and temperature if that's the field thing you mean $\endgroup$
    – K Tech
    Nov 23 '20 at 21:53
  • $\begingroup$ Yes that's what I was getting after. Those are important if you are trying to create a decent material for the vdb. $\endgroup$
    – Timaroberts
    Nov 23 '20 at 22:02
1
$\begingroup$

In many cases you should have at least some basic grids included to render a decent result. (Here I'm using a vdb I have on my system as an example, you should be able to follow along just fine)

  • Firstly, check what grids you have available here:

enter image description here

  • Second check the step size setting in the render section of the volume object. As it appears to currently be too coarse, try to lower it some. Perhaps it will help. See the documention on the Volume Object

enter image description here


  • Using the grids we have available, you can now build a nice material like this(based on your comments, this particular vdb has more grids available, so could have a more complex material if desired): enter image description here click to enlarge

  • In this example, the render looks like this:

enter image description here

$\endgroup$
4
  • $\begingroup$ But I lowered the step size to .000001 and it still looks the exact same I don’t really now what else to change $\endgroup$
    – K Tech
    Nov 23 '20 at 22:17
  • $\begingroup$ Or am I lowering it to much ? $\endgroup$
    – K Tech
    Nov 23 '20 at 22:21
  • $\begingroup$ Nope this didn’t really change anything it still looks the exact same $\endgroup$
    – K Tech
    Nov 23 '20 at 22:42
  • $\begingroup$ Please help I didn’t fix it $\endgroup$
    – K Tech
    Nov 23 '20 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.