0
$\begingroup$

I am following a sword tutorial and when i try to plug in either a Emission shader or Volume Scatter shader in to the world output volume node weird overexposure and artifacts appear in the render preview: Artifacts with Emission

Artifacts with Volume Scatter

When i actually render the image it is fine. It is just the preview that is having problems. The render engine used is Eevee and i'm using blender 2.90.1. Actual render result

Now i have tried to look at the different render passes to see if i can pinpoint the problem. The render pass bloom shows the same effects so i have tried to disable it but then it just show less glowing artifacts so i'm guessing that wasn't it. For Emission it seems the render passes Volume Scattering and Volume Transmittance show a rather overexposed picture but only in preview mode.

Does anyone know what is causing these differences between the render preview and the actual render?

Update: Added blend file:

Also added

$\endgroup$
8
  • $\begingroup$ What is your setup in 3d view editor under render view properties? $\endgroup$ – vklidu Nov 23 '20 at 21:18
  • $\begingroup$ @vklidu in the second image the render properties are visible or do you mean a different menu? If not Ambient Occlusion and Bloom are turned on. If turned off it simply results in less shiny artifacts. Any other settings/values you think could cause this? $\endgroup$ – SED9008 Nov 24 '20 at 8:08
  • $\begingroup$ I mean this one imgur.com/Q0bWvIJ or just if you can upload blend-exchange.giantcowfilms.com simplified blend with just a part that still produce the issue (I saw already asked for the same, but I cant find it). $\endgroup$ – vklidu Nov 24 '20 at 8:40
  • $\begingroup$ @vklidu it looks the same as the picture you posted. I also added the blend file to the post. Thanks for helping! $\endgroup$ – SED9008 Nov 24 '20 at 9:28
  • 1
    $\begingroup$ @vklidu it was the driver. Thanks again for your help! $\endgroup$ – SED9008 Nov 24 '20 at 22:00
1
$\begingroup$

I was running intel hd 520 graphics with a very old driver (2016). After updating the driver the peoblem was solved.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.