2
$\begingroup$

enter image description hereSo, started my Blender journey yesterday working on a tutorial to create some mountains and animate a fly-through of them. They are made with the A.N.T. mesh tool and microdisplacements. I've worked my way through the tutorial to a point where I'm actually rendering frames, and it's much slower than I anticipated it would be. It's taking 5-7 minutes per frame. I am using Cycles with Auto Tile Size addon, and am using an 8k HDR texture (I think that's how I should refer to it) to light the world.

My PC specs are RTX 3090, Ryzen 3950X and 128GB of RAM. During each frame render, the GPU and CPU are essentially idle until the last little bit when Blender starts actually showing tiles, then my GPU kicks in and renders those out in a matter of seconds. Is that to be expected? Is there any way to get Blender to actually utilize my hardware during the first several minutes of rendering, where it seems like it's just barely using it?

I'm rendering using Cycles in Blender 2.91 and here's a screenshot with what I'm rendering and all of the associated settings.

This is the tutorial that I am following: https://www.youtube.com/watch?v=qSafYNQrodk

Thanks for any insight!

$\endgroup$
20
  • $\begingroup$ You can select both your CPU and GPU in CUDA settings - you don't have to pick one or the other. Also, make sure to select your GPU under OptiX. $\endgroup$ Commented Nov 23, 2020 at 6:21
  • $\begingroup$ Hey Christopher, appreciate the response. I've tried doing both, and it didn't change much. What's taking the majority of the time is the 'setup' before the actual rendering takes place. Like 'Tessellating Landscape", which takes almost 2 minutes, while my CPU and GPU are seemingly idle. I am hoping to improve performance on that part of the process. As a test, I just rendered a frame without the micro displacements active, and it only took 2 minutes, so I guess that's what's taking the most time. Any recommendations as far as speeding that up? Cheers! $\endgroup$ Commented Nov 23, 2020 at 6:29
  • $\begingroup$ I'm not sure other than that. I have never used the Auto Tile addon, and don't often use Ant Landscape for extremely detailed meshes, and therefore cannot speak to either of their influence(s) on a render (if any). It could just be that it's taking a long time building the BVH (because of the micro displacements) or that blender is not optimized for tessellation on that scale. $\endgroup$ Commented Nov 23, 2020 at 6:41
  • 1
    $\begingroup$ Hey, Gordon and Christopher: I think I may have an answer as to why my rendering is taking so long. I brought up the statistics window, and I have 5.2 million vertices and faces, and 10 million triangles and edges. In the tutorial I'm watching, the author has only 760k verts and faces, and he's rendering each frame in about 50 seconds. One place where I veered off from his tutorial was when I did subdivisions, perhaps I went a little bit overboard. I'm going to take the time to re-do this tutorial but follow his lead more closely and see how that works out. $\endgroup$ Commented Nov 23, 2020 at 8:41
  • 3
    $\begingroup$ Just an update - it was the extreme vert/face count that was causing the slowdown. I remade everything with less subdivision and it was substantially faster. Thanks again for all the replies! $\endgroup$ Commented Nov 24, 2020 at 0:56

1 Answer 1

-1
$\begingroup$

I never used it but the e-cycles plugin might help if you had to keep the subdivision : https://blendermarket.com/products/e-cycles

« What’s more, thanks to a new option called "Persistent Data", for fly-through animations where only the camera moves, E-Cycles only needs to do the pre-processing step once for all frames. In the example above, rendering takes just 3 seconds per frame on a single GPU. In this case, the persistent data option saves 7 seconds of pre-processing per frame. »

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .