I am making a mesh in which all vertices need to be in specific locations. My minimum unit of distance is 0.125m, so that all vertices will be at distances from each other or the point 0 of the map with a value of 0.125 times X (ie:2.125, 0.5, 1.75 etc.). However I discovered that after using the bevel tool (I may have done something wrong), there are vertices that are not perfectly aligned. Some are 0.0000002 further than another ones on a certain axis for example. I could realign them by hand but it takes me a long time.

My questions are: A. Are my doing something wrong? B. Can I correct this by selecting all the vertices and then using Shift+S and then "Selection to Grid" but with a specific distance, so that they all move to the closest point on the 0.125 units from 0 point on map?

I am sorry I am having trouble explaining the concept, I hope it is understood.


1 Answer 1


You can change the grid unit settings and snap to the grid:

enter image description here

Though, 0.0000002 could be a floating point accuracy issue.

  • $\begingroup$ Dear lemon, that was exactly what I was looking for. Thank you so much. $\endgroup$
    – Coldsun
    Nov 21, 2020 at 12:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .