2
$\begingroup$

I'm working on creating a normal map for a simplified mesh based on a sculpt. I switched to cycles, checked "selected to active", made the simplified mesh active, selected the sculpt, and baked the normal map.

Unfortunately, after applying the normal map to the simplified mesh, the mesh appears to have holes in it. I've also noted that the normal map appears to be mostly green.

The simplified mesh, appearing to have holes in it, and the normal map, appearing mostly green.

I originally thought it was due to the messy topology of the sculpt, so I duplicated the sculpt, remeshed it, and tried again, with the same results.

Why does my normal map make my mesh appear to have holes in it?

$\endgroup$
5
  • 1
    $\begingroup$ Try to add some extrusion in the bake settings. $\endgroup$
    – lemon
    Nov 21, 2020 at 10:12
  • $\begingroup$ Alright! I changed the extrusion to 0.5m, but that seems to have made things a bit stranger. My normal map looks less green though, so it looks like I'm making some progress, but something still isn't right here... $\endgroup$
    – MEATTAIL
    Nov 21, 2020 at 11:14
  • $\begingroup$ 0.5 is probably too much. Also check the normals of your models. $\endgroup$
    – lemon
    Nov 21, 2020 at 11:19
  • $\begingroup$ I experimented a bit, lowered the extrusion to 0.025, and things are starting to look a lot better. However, there are still some oddities. Is there anything else I can do to fix this, or will I have to turn to photoshop to edit them out? $\endgroup$
    – MEATTAIL
    Nov 22, 2020 at 6:53
  • $\begingroup$ You can use a cage object which can be a copy of your lowpoly model with some deformation at the oddities. $\endgroup$
    – lemon
    Nov 22, 2020 at 6:56

0

You must log in to answer this question.

Browse other questions tagged .