1
$\begingroup$

I'm using a script to generate a mesh:

https://gist.github.com/dwatrous/efa2ea82fc2269e59afa182bf5ced0df

I have my scene units set at millimeters with a scale factor of 1 enter image description here

For some reason, when I run my script, it produces a mesh that's about a 1000 times larger, so I have to scale it by 0.001 in order to have it be the expected size. However, even then, the size still isn't right and the resulting mesh isn't the exact size I intend from the script.

enter image description here

Is there some way in the script to have it produce a mesh of the expected size?

$\endgroup$
1
  • $\begingroup$ In unit settings as above default cube is 2000mm cubed, ie 1 blender unit is still 1 meter. If you wish to input 22 mm use 22 / 1000. (Or make script an operator and set the radius property subtype to 'LENGTH'. - $\endgroup$ – batFINGER Nov 18 '20 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.