4
$\begingroup$

Even in orthographic views there is 0 control over the depth at which it draws. you draw a line, then pan even a tiny amount and it's obvious the line is nowhere near where it first appeared. I have even experienced it seeming to draw behind the viewport camera position? Not to mention trying to point to a specific vertex or face, where it will randomly draw in front or behind the mesh. I was wondering if anybody has managed to use this tool successfully. Am I missing a vital setting?

I am in 2.9 by the way.

thanks for reading!

$\endgroup$
0
3
$\begingroup$

By default the depth is determined by the 3D cursor position.

All the settings are in the N panel > Tool > Active Tool > Placement, you can choose between:

  • 3D Cursor: The annotation is drawn perpendicularly to your view and it is placed where your 3D cursor is.
  • View: The annotation does not depend on the 3D view.
  • Surface, The annotation is drawn on the surface of the objects.

enter image description here

Also good to know: Ctrl left click to erase (if you use the D shortcut to draw annotation, the erase shortcut is D and right click).

Click on N panel > Tool > Active Tool > Note to set the thickness and color of the stroke.

CLick on the "+" and "-" button to create or delete an annotation, click on the eye icon to switch it visibility:

enter image description here

If you move in the Timeline and draw again, by default it will create a new annotation that starts at this frame. If you want to keep the previous one, click on the Note > Frame: X (Locked) button. To unlock, click again on this button. To delete this annotation on all its frames, click on the X button.

enter image description here

$\endgroup$
3
  • $\begingroup$ Oh right I wasn't aware you could directly draw with the D shortcut. Makes sense I guess ? $\endgroup$ – Gorgious Nov 16 '20 at 13:00
  • $\begingroup$ yes it's convenient, but to set the annotation preferences you need to select the tool and go into the tool panel $\endgroup$ – moonboots Nov 16 '20 at 13:07
  • $\begingroup$ Thanks for the detailed response, very informative and helpful! $\endgroup$ – skinnypete Nov 16 '20 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.