0
$\begingroup$

In an animation I did where the camera flys around a fishing shack, there is a ball in the sky with white emission that shows up on in the Viewport but doesn't when rendered. Initially I thought it had to do with a cube in front of a spot off to the side of the frame, put there to create a light stream, that blocks the view of the "moon". But, when I turned it off, it still cannot be seen. Render with the cube 'on' Viewport with cube 'on' Viewport with cube 'off' The camera has a view of 2000m, which I believe is sufficient.

Interestingly, when I had Concierge Render crank out the whole film, this is what this frame looked like (before I made alterations to render settings. enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ You're showing the result, but nothing about the settings. Could you show what is the moon settings (rendering parts). Or upload your file using blend-exchange.giantcowfilms.com and paste the obtained link here (editing your question or in comments) $\endgroup$ – lemon Nov 14 '20 at 19:40
  • $\begingroup$ Here you are.<img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=ozeA3gGg" /> $\endgroup$ – Tim Scott Nov 14 '20 at 20:16
  • $\begingroup$ Cube 112 is disabled from viewport visibility but not from rendering in Outliner.If you want to use this cube for its volume effect, lower Density like 0.001 BTW next time it is better to simplified scenne before upload, fle is lighter, for us easier to orientate and sometimes you can discover issue just by deleting parts of a scene :) Thank you $\endgroup$ – vklidu Nov 14 '20 at 21:47
  • $\begingroup$ Thanks, Vklidu. How do I disable for viewport AND render.... or disable for render but not viewport. Basically.. I didn't know that there are two disable switches. As for deleting scenes, I started with 34MB and deleted some. Sorry for the heavy file. I know now to lighten even more when asking for help. $\endgroup$ – Tim Scott Nov 14 '20 at 22:29