0
$\begingroup$

I'm using version 2.9. I'm having trouble figuring out how to scale down an object in only one direction, so as to flatten it out. When I do this, however, it also shears the object, which is not desired.

I hit s for scale, then z for constraining to the z axis. It will highlight the global z axis (which is what I want), but when I drag the mouse to scale, it is clearly scaling to another axis, which is a few degrees off and results in the undesirable skew.

If I hit z again, it switches the highlighted axis to what I assume is somehow the local axis of the object, which is a few degrees different than the global z axis. When I now drag the mouse, it scales in what visually appears to be exactly the same way as previously, but which does at least appear to be consistent with the new local z axis that is being demonstrated. I actually get the same skew when I scale to the view or cursor as well.

I've tried using Object > Apply > Rotation with the thought maybe that would clear out whatever angle the object thinks it's at, but that doesn't enable me to apply the desired scale without the shearing effect. If I do Object > Transform > Apply to transform orientation, it will rotate the object a little bit to about the same orientation that my skew problem is. So it makes it seem like there's a transform orientation that I need to somehow reset or zero out.

$\endgroup$
3
  • $\begingroup$ Hey, can you share a screenshot with us? $\endgroup$
    – Atti
    Nov 14, 2020 at 18:15
  • $\begingroup$ You should use Alt+R to clear the rotation instead of applying it, maybe. $\endgroup$
    – lemon
    Nov 14, 2020 at 18:18
  • $\begingroup$ I've tried Alt+R at your suggestion but it's still doing this. I'm attaching a demonstration of what's happening. [![Example of phenomenon][1]][1] [1]: i.sstatic.net/9CJBS.gif $\endgroup$ Nov 16, 2020 at 15:38

2 Answers 2

0
$\begingroup$

I just had this exact same behaviour in Blender 3.0.1, and since none of the above solutions worked for me, i thought this might prove useful to others like me.

There is a dropdown with three little arrows(coordinate axis) left of the magnet icon at the top of the screen (right above the Viewport). Its used for setting the "Transformation Orientation". Mine was set to "View", setting it to "Global" fixed the behaviour.

$\endgroup$
-2
$\begingroup$

I had the same problem and what solved it for me was to select the object(s), Ctrl + A, then select Rotation.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .