0
$\begingroup$

This is how my viewport looks in the "Layout" tab:

enter image description here

Strangely, it looks fine in every other tab. This is from the "Modeling" tab:

enter image description here

  • This is only happening with this file; new files render as expected.
  • This happens with every scene in this file (including brand new scenes).

The closest thing I could find online was something about viewport rendering being "paused," but I couldn't figure out where I could find that setting. I suspect it's something quite simple, but I'm pretty new to the program.

Thanks in advance for your time and help :)

EDIT: I have no idea what caused this issue, but I managed to resolve it by deleting my "Layout" tab, then creating a new "Layout" tab with the "Add Workspace" button. Everything seems to be working as expected again.

$\endgroup$
6
  • 1
    $\begingroup$ Yeah, that's weird. I downloaded the file, and it's happening on my end too, so you can rule out GPU/Driver issues and anything to do with a broken blender install. I can't figure out how to get rid of it, though. It looks like z-fighting, or massive shading artifacts, but it even happens to new created primitives so it can't be that. Very strange.. I'll keep looking, but I dunno.... $\endgroup$ – Christopher Bennett Nov 14 '20 at 3:25
  • $\begingroup$ @ChristopherBennett Well, at least I'm not crazy. I have a fresh file open on another window and I'm comparing every setting I can find to this wonky file, but I haven't found the culprit yet. Thanks for your help. If it comes to it, I'll just make a new file and import all my objects from this file, but I'd really like to figure out what's causing this in case it happens again. $\endgroup$ – Max Williams Nov 14 '20 at 3:31
  • $\begingroup$ If you want to see something stranger - turn on face orientation. Recalculating normals does nothing to fix it. I think you created an impossible object. $\endgroup$ – Christopher Bennett Nov 14 '20 at 3:42
  • $\begingroup$ @ChristopherBennett Haha. I can't test that anymore because I sorta fixed it. Since it was only doing this in the Layout tab, I just deleted that tab and added a new Layout tab with the Add Workspace button, and that appears to have fixed everything. I have no idea what caused this to happen in the first place, but I suppose this a reasonable solution. $\endgroup$ – Max Williams Nov 14 '20 at 3:47
  • $\begingroup$ Glad you got it fixed. That's one of the weirdest things I've ever seen in all my time using blender. Here's the face orientation if you're curious (although you only get the "full effect" when you're moving around it) - ibb.co/Twv09dc $\endgroup$ – Christopher Bennett Nov 14 '20 at 3:51
0
$\begingroup$

I'm not sure about what's happening, but turning off "cavity" from the viewport setting could fix the view. When I render it out on both EEVEE and cycles, it doesn't seem glitching. Make sure it's turned off

(Make sure it's turned off)

$\endgroup$
1
  • $\begingroup$ Thanks for taking the time to investigate! With Cavity unchecked and Backface Culling checked, that appears to fix the issue, but something's clearly still going on because those settings are both unchecked by default. $\endgroup$ – Max Williams Nov 14 '20 at 3:35
0
$\begingroup$

I'm still not sure exactly what caused this, but I managed to resolve it by deleting my "Layout" tab, then creating a new "Layout" tab with the "Add Workspace" button. Everything seems to be working as expected again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.