2
$\begingroup$

I can do a falling torus onto a plane, but I wanna have a modification: a ball moving upwards on a skewed plane and then slowing and increasing the velocity in the opposite direction as would physics suggest. My question is: how do I give the ball an initial velocity?

$\endgroup$
6
  • $\begingroup$ so the ball needs to have physics from the beginning except it's going upwards? $\endgroup$
    – moonboots
    Commented Nov 12, 2020 at 17:42
  • $\begingroup$ @moonboots mostly yes. It should just have an initial velocity so no violation of physics occurs as it moves upwards the plane. I just do not know ho do I give it this initial velocity. I expect Blender then correctly and automatically gives it the opposite velocity (smoothly) in the opposite direction. $\endgroup$ Commented Nov 12, 2020 at 17:45
  • $\begingroup$ @moonboots What do you mean by "have physics" ? "obey physics" or "have initial velocity" instead of physics ? $\endgroup$ Commented Nov 12, 2020 at 17:46
  • $\begingroup$ at the beginning you could animate your object with the Rigid Body > Settings > Animate option that you can keyframe, but it will be animation, not physics, then disable this option, keyframe, and let the physics act on the object $\endgroup$
    – moonboots
    Commented Nov 12, 2020 at 17:52
  • $\begingroup$ @moonboots I have found the 2 buttons in Mass Dynamic and Animated, but I do not know how to use them. I'm a beginner and not familiar with the "keyframe" concept. Perhaps you could give me some hints to begin with. This specific question of mine is hard to seek in google which I would consult in other case. $\endgroup$ Commented Nov 12, 2020 at 17:59

1 Answer 1

3
$\begingroup$

There might be another solution but I don't know it. So what you could do is:

  • Give your object a Rigid Body > Type > Active, create your slope, Type > Passive.

  • Put your object on the bottom, make sure it doesn't come across the surface, give your object a keyframe (i) > Location, Rotation and Scale, enable the Rigid Body > Animated option and give it a keyframe as well (put your mouse cursor over the option and press i):

enter image description here

  • Several frames later, move the cube a bit, create a second keyframe for your object, then disable the Animated option and keyframe again:

enter image description here

  • If the initial momentum is strong enough, it should work fine:

enter image description here

File:

$\endgroup$
16
  • $\begingroup$ I'm trying to understand what's going on here and sounds correct. Could you provide me with a .blend file ? $\endgroup$ Commented Nov 12, 2020 at 18:33
  • $\begingroup$ sure, I've edited my answer $\endgroup$
    – moonboots
    Commented Nov 12, 2020 at 18:35
  • $\begingroup$ Good. Now I just want to make it moving. Where do I enable it as in your last picture ? There is missing the |> button at the bottom. $\endgroup$ Commented Nov 12, 2020 at 18:41
  • 1
    $\begingroup$ spacebar to play, shift left arrow to go to frame 0 $\endgroup$
    – moonboots
    Commented Nov 12, 2020 at 18:47
  • 1
    $\begingroup$ as I said, make sure that the cube doesn't touch the surface of the slope, it's the problem here, the cube goes through the surface at frame 0 and 5 $\endgroup$
    – moonboots
    Commented Nov 12, 2020 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .